summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpcast')
-rw-r--r--net-misc/udpcast/Manifest1
-rw-r--r--net-misc/udpcast/files/udpcast-20120424-fd_set.patch11
-rw-r--r--net-misc/udpcast/files/udpcast-20120424-gentoo.patch12
-rw-r--r--net-misc/udpcast/metadata.xml13
-rw-r--r--net-misc/udpcast/udpcast-20120424-r1.ebuild34
-rw-r--r--net-misc/udpcast/udpcast-20120424.ebuild27
6 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/udpcast/Manifest b/net-misc/udpcast/Manifest
new file mode 100644
index 000000000000..17080889397f
--- /dev/null
+++ b/net-misc/udpcast/Manifest
@@ -0,0 +1 @@
+DIST udpcast-20120424.tar.bz2 138955 SHA256 d6c30352571a3215f00f8451d0fe932ba24ed5f98653d3aeb554e3c43c079677 SHA512 b28ada43f9f3cba498ffff3032cff6a673584836439275604c1201a18fe2e37f2c847a48b72783065b1656a7a2f9e9739d8a376e90df8b05749bc2e2f64278de WHIRLPOOL 9d8d48fabe30f462e49d2b1dc0b2d190fd5b0e6d1e68f801209a61782185464a952dd46ffbed9a6d39a3da8fce6de99f68916b3ef447db6d0fcc1523a83cc4de
diff --git a/net-misc/udpcast/files/udpcast-20120424-fd_set.patch b/net-misc/udpcast/files/udpcast-20120424-fd_set.patch
new file mode 100644
index 000000000000..2bd5bd5ce801
--- /dev/null
+++ b/net-misc/udpcast/files/udpcast-20120424-fd_set.patch
@@ -0,0 +1,11 @@
+--- a/console.h
++++ b/console.h
+@@ -6,6 +6,8 @@
+ #include <winbase.h>
+ #endif /* __MINGW32__ */
+
++#include <sys/select.h>
++
+ #define prepareConsole udpc_prepareConsole
+ #define getConsoleFd udpc_getConsoleFd
+ #define restoreConsole udpc_restoreConsole
diff --git a/net-misc/udpcast/files/udpcast-20120424-gentoo.patch b/net-misc/udpcast/files/udpcast-20120424-gentoo.patch
new file mode 100644
index 000000000000..e4269a0873a6
--- /dev/null
+++ b/net-misc/udpcast/files/udpcast-20120424-gentoo.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -30,8 +30,7 @@
+
+ # For additional warnings & checks, add -Wstrict-prototypes -Wshadow to the
+ # following:
+-CFLAGS +=-Wall -DBB_FEATURE_UDPCAST_FEC -D_FILE_OFFSET_BITS=64 -DUSE_SYSLOG -DUSE_ASSEMBLER -O6
+-LDFLAGS +=-s
++CFLAGS +=-Wall -DBB_FEATURE_UDPCAST_FEC -D_FILE_OFFSET_BITS=64 -DUSE_SYSLOG
+ LIBS +=@LIBS@
+
+ BUSYBOX=../udp-busybox/busybox
diff --git a/net-misc/udpcast/metadata.xml b/net-misc/udpcast/metadata.xml
new file mode 100644
index 000000000000..526d84b8a3cd
--- /dev/null
+++ b/net-misc/udpcast/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>
+UDPcast is a file transfer tool that can send data simultaneously to
+many destinations on a LAN. This can for instance be used to install
+entire classrooms of PC's at once. The advantage of UDPcast over using
+other methods (nfs, ftp, whatever) is that UDPcast uses Ethernet's
+multicast abilities: it won't take longer to install 15 machines than it
+would to install just 2.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/udpcast/udpcast-20120424-r1.ebuild b/net-misc/udpcast/udpcast-20120424-r1.ebuild
new file mode 100644
index 000000000000..202047f7598d
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20120424-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="http://www.udpcast.linux.lu/"
+SRC_URI="http://www.udpcast.linux.lu/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fd_set.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+ use hardened || append-cflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}
diff --git a/net-misc/udpcast/udpcast-20120424.ebuild b/net-misc/udpcast/udpcast-20120424.ebuild
new file mode 100644
index 000000000000..4f7515388c2e
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20120424.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="http://www.udpcast.linux.lu/"
+SRC_URI="http://www.udpcast.linux.lu/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fd_set.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}