summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.03.03.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 2f35560427bc..e66163a011f4 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2021.02.22.tar.gz 3293733 BLAKE2B 83c3d53624a5e2dd1e901fbdbf90e95dc43c632c8bb263e25121c7a68beffe495e481c52d35b822a82a885eb4c4836c1567fd174ac57cedbc18bbb9768f43dc0 SHA512 eaecddf40759777c00abc1b456d8f55dd2ef242a8445970dd655a21dd148459c2c538a4b04fafddbdd295911a96e432a926c5f26e5a29c993fb3bc10f0ca1b9b
DIST youtube-dl-2021.03.02.tar.gz 3302162 BLAKE2B c1ccc5822061f0d815ada19827cada576817acd1ec7d18410a021fc599b7ebd456a4d913475b7649eae8c75d757860d5bb1a76a51be740ba880746ff585700e4 SHA512 1318434c009a9eb41231bb7897b16fd72fde5d3165f6a24ff97031ed89b4d6408520242c71270f12b4f55dfa97ca48d42c6f167ad036eca74241e61cb950c298
+DIST youtube-dl-2021.03.03.tar.gz 3303114 BLAKE2B f63f2aedb6494b22156df08b5aaa2c4438614fd99a7e2d45baaa754c71a278a2c22051086f578f54b4cfa6384aaf5e08e61d42b8023a754805a65e6b6a79ea58 SHA512 0a554ee6805ceaa1c68eab83be3bd6046bc56a26658c705e231f907c2970cdeb441e0ae57d5013385810b5bbee7e4de3ac7f6df36c3eef76a6fa9c5424b921a2
diff --git a/net-misc/youtube-dl/youtube-dl-2021.03.03.ebuild b/net-misc/youtube-dl/youtube-dl-2021.03.03.ebuild
new file mode 100644
index 000000000000..9b024e43dbba
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.03.03.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}