summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/canto-curses/canto-curses-0.9.9.ebuild')
-rw-r--r--net-news/canto-curses/canto-curses-0.9.9.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/net-news/canto-curses/canto-curses-0.9.9.ebuild b/net-news/canto-curses/canto-curses-0.9.9.ebuild
index d84861c52fb5..197bed128f60 100644
--- a/net-news/canto-curses/canto-curses-0.9.9.ebuild
+++ b/net-news/canto-curses/canto-curses-0.9.9.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="ncurses(+),threads(+)"
inherit distutils-r1 multilib
@@ -15,12 +15,27 @@ SRC_URI="https://github.com/themoken/canto-curses/archive/v${PV}.tar.gz -> ${P}.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="test"
+PROPERTIES="test_network"
RDEPEND=">=net-news/canto-daemon-0.9.1[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
python_prepare_all() {
# Respect libdir during plugins installation
sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+ # Test fails because of lost site
+ rm tests/test-config-function.py || die
+
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local test_file
+ for test_file in tests/*; do
+ "${EPYTHON}" "${test_file}" || die "Test ${test_file} failed with ${EPYTHON}"
+ done
+}