summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/Manifest1
-rw-r--r--net-nntp/tin/tin-2.4.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index 227280686a98..23e38f46d03c 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1,3 +1,4 @@
DIST tin-2.0.1.tar.bz2 1758848 BLAKE2B 63a6302724c405114b3d692d7b283ca3ea297661055ada944b95a46d27a23a371f9d16929888c41b6e95a6e1a16b5bba964467ff57d26a1ba81a951a68c7ac2a SHA512 fc2bd0586e72a2fb4f8a223c0ceeb19e2dfcdb300d463f0f5d4b7367346a032614aa662a4d9d11673269be59cbaeff39fa3fdf7618dd41e965850d137919a386
DIST tin-2.2.1.tar.xz 1378384 BLAKE2B d68157e778f272c55cb3021987beddb27e89bd31d39e985b16e51a4aa942cb59abcc6ada46611c69320e785506085210a0451227091964866b4130e99c5f1ac5 SHA512 2c5b4b50be38c168404ba55c9429355c0dd2232c580116086fa9ea24a8907ad2d71d91b2d1c533bf7ff4d24fd1946d5ba61bc0833b20d5383e013e2f18c10bbd
DIST tin-2.3.1.tar.xz 1381840 BLAKE2B c6ccf0b41b56acc5e3628b32eba62502e4f01e1f0db2936d8aebbfafb27a4cbc7fbd1664e4d646d8e3128ee4b7a17dbc55e7ea93b7eda68c1518b4303bcdaecd SHA512 53fecc8fca7c67a7082a1f3f77a868433725a2ad4cc5650cdd522f791cbfc336733db5de3c637606788a2844df7e13e1d3fbae48c15ceaa49e24ea6e297926af
+DIST tin-2.4.2.tar.xz 1491388 BLAKE2B 16fab433443d5859cc9661790ff837e8f45767e7f45bafc54a8cffc94fd52cb4ee7afb98e579db49c16148b0f521374404a0f26d75a07a24c1c7a1dc5e3a57fe SHA512 70a9957d5bf5af1bb182a3f4e62795cd5862b7282b7fc0c231c3bd02d83950cdbdd502d8a2cc5eae20b29af584e4f794f03378742b47ed93fc5c61ac5bbb01b6
diff --git a/net-nntp/tin/tin-2.4.2.ebuild b/net-nntp/tin/tin-2.4.2.ebuild
new file mode 100644
index 000000000000..1846e91b8354
--- /dev/null
+++ b/net-nntp/tin/tin-2.4.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses:0[unicode?]
+ unicode? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable etiquette) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen}
+}
+
+#src_compile() {
+# emake build
+#}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}