summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoinxtd')
-rw-r--r--net-p2p/bitcoinxtd/Manifest1
-rw-r--r--net-p2p/bitcoinxtd/bitcoinxtd-0.11.0.ebuild120
-rw-r--r--net-p2p/bitcoinxtd/bitcoinxtd-0.11.0d.ebuild6
-rw-r--r--net-p2p/bitcoinxtd/files/bitcoinxt.conf8
4 files changed, 4 insertions, 131 deletions
diff --git a/net-p2p/bitcoinxtd/Manifest b/net-p2p/bitcoinxtd/Manifest
index 68b66963d777..f5c7d53244a7 100644
--- a/net-p2p/bitcoinxtd/Manifest
+++ b/net-p2p/bitcoinxtd/Manifest
@@ -1,2 +1 @@
-DIST bitcoinxtd-0.11.0.tar.gz 5226736 SHA256 f6fc1651b3cad90bae6f9d70a5f476ca4cd9b8b38681331bccc6d2651c5e2c89 SHA512 044f2b95644b831641fc48fe65e980438e58e784635b32f393e9aeb6473124708df3870aa3bd3848acd90b4b9785fba9163ad07e5ea7d243c175741429bc2b6b WHIRLPOOL 5b2e692e0ccafff454260bb1f8871bec2775c21124e22cf11fd3d175b2d25634fc514e0cfe6b6334e20692846319e9f5fd1a580d8ef31389d6e84025bc600eaa
DIST bitcoinxtd-0.11.0d.tar.gz 5408217 SHA256 66b4bd52ed8b97e28da46ac552396c40853a9d7f765063603552e1cf118a2227 SHA512 98dd980c1cc65006160819f0e9045bc962cc6faddbde22f7bfea4bbcfef4662a5c1280386f9f68b42bc3e3e99e89ecf02d211fe20107bba57c14e6b3017a339c WHIRLPOOL 9468d20db5ec7e6f5d4f96156ab5568f0870ccb4b8037a9ec3bb0e3636a59f07a846ca731ebe99affda5cfbcd3ec117beeaff025f7aad0ab23a88379ae2c1b23
diff --git a/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0.ebuild b/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0.ebuild
deleted file mode 100644
index 78c23669c929..000000000000
--- a/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DB_VER="4.8"
-
-inherit db-use autotools eutils toolchain-funcs user systemd
-
-DESCRIPTION="BitcoinXT crypto-currency wallet for automated services"
-HOMEPAGE="https://github.com/bitcoinxt/bitcoinxt"
-My_PV="${PV/\.0/}A"
-SRC_URI="https://github.com/bitcoinxt/bitcoinxt/archive/v${My_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="+doc +ssl +logrotate +upnp +wallet"
-
-OPENSSL_DEPEND="dev-libs/openssl:0[-bindist]"
-WALLET_DEPEND="media-gfx/qrencode sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]"
-
-RDEPEND="
- app-shells/bash:0
- sys-apps/sed
- dev-libs/boost[threads(+)]
- dev-libs/glib:2
- dev-libs/crypto++
- ssl? ( ${OPENSSL_DEPEND} )
- logrotate? ( app-admin/logrotate )
- wallet? ( ${WALLET_DEPEND} )
- upnp? ( net-libs/miniupnpc )
- virtual/bitcoin-leveldb
-"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/bitcoinxt-${My_PV}"
-
-pkg_setup() {
- local UG='bitcoinxt'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoinxt "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/9999-syslibs.patch"
- eautoreconf
-}
-
-src_configure() {
- local my_econf=
-
- if use upnp; then
- my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
- else
- my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
- fi
- if use wallet; then
- my_econf="${my_econf} --enable-wallet"
- else
- my_econf="${my_econf} --disable-wallet"
- fi
- my_econf="${my_econf} --with-system-leveldb"
- econf \
- --disable-ccache \
- --disable-static \
- --without-libs \
- --without-utils \
- --with-daemon \
- --without-gui \
- ${my_econf} \
- "$@"
-}
-
-src_compile() {
- local OPTS=()
-
- OPTS+=("CXXFLAGS=${CXXFLAGS} -I$(db_includedir "${DB_VER}")")
- OPTS+=("LDFLAGS=${LDFLAGS} -ldb_cxx-${DB_VER}")
-
- use ssl && OPTS+=(USE_SSL=1)
- use upnp && OPTS+=(USE_UPNP=1)
-
- cd src || die
- emake CXX="$(tc-getCXX)" "${OPTS[@]}" bitcoind
- mv bitcoind ${PN}
-}
-
-src_install() {
- local my_topdir="/var/lib/bitcoinxt"
- local my_data="${my_topdir}/.bitcoinxt"
-
- dobin src/${PN}
-
- insinto "${my_data}"
- doins "${FILESDIR}/bitcoinxt.conf"
- fowners bitcoinxt:bitcoinxt "${my_data}/bitcoinxt.conf"
- fperms 600 "${my_data}/bitcoinxt.conf"
-
- newconfd "${FILESDIR}/bitcoinxt.confd" ${PN}
- newinitd "${FILESDIR}/bitcoinxt.initd" ${PN}
- systemd_dounit "${FILESDIR}/bitcoinxtd.service"
-
- keepdir "${my_data}"
- fperms 700 "${my_topdir}"
- fowners bitcoinxt:bitcoinxt "${my_topdir}"
- fowners bitcoinxt:bitcoinxt "${my_data}"
-
- if use doc; then
- dodoc README.md
- dodoc doc/release-notes.md
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoinxtd.logrotate" bitcoinxtd
- fi
-}
diff --git a/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0d.ebuild b/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0d.ebuild
index cb87a52c7078..c4d3929240b9 100644
--- a/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0d.ebuild
+++ b/net-p2p/bitcoinxtd/bitcoinxtd-0.11.0d.ebuild
@@ -16,9 +16,11 @@ SRC_URI="https://github.com/bitcoinxt/bitcoinxt/archive/v${My_PV}.tar.gz -> ${P}
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="+doc +logrotate +ssl +upnp +wallet"
+IUSE="+doc libressl +logrotate +ssl +upnp +wallet"
-OPENSSL_DEPEND="dev-libs/openssl:0[-bindist]"
+OPENSSL_DEPEND="
+ !libressl? ( dev-libs/openssl:0[-bindist] )
+ libressl? ( dev-libs/libressl )"
WALLET_DEPEND="media-gfx/qrencode sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]"
RDEPEND="
diff --git a/net-p2p/bitcoinxtd/files/bitcoinxt.conf b/net-p2p/bitcoinxtd/files/bitcoinxt.conf
deleted file mode 100644
index c6a55f3d9133..000000000000
--- a/net-p2p/bitcoinxtd/files/bitcoinxt.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-# http://www.bitcoin.org/smf/index.php?topic=644.0
-#rpcuser=
-#rpcpassword=
-
-
-
-
-