summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/deluge-9999.ebuild')
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 579b78ef727a..e11f9c01a2c6 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -56,11 +56,13 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-_distutils-r1_create_setup_cfg() {
+esetup.py() {
# bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
# Override this call from the distutils-r1 eclass.
# This does not respect the distutils-r1 API. DONOT copy this example.
- :
+ set -- "${PYTHON}" setup.py "$@"
+ echo "$@"
+ "$@" || die
}
python_install_all() {