summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gtk-gnutella')
-rw-r--r--net-p2p/gtk-gnutella/Manifest1
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.1.7.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index 14782362c6b2..bc8fc00a9c04 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,2 +1,3 @@
DIST gtk-gnutella-1.1.5.tar.bz2 19552392 SHA256 c332043a885ba302841a261c118264d903627fd21b062c99538db7dc7dada8a5 SHA512 eb94ef5cbc447ebf75d16eb24f0a4d88197a9b79f842fe73f963af3ba5985cc4ce99605d29e33123754d9a509218b71acc684df27a075c3947278211c1b204e5 WHIRLPOOL c5bc302dd7bd92eac2298c52b557723b473a930a7e1b40cddc74424bef7acf0a9b90f27ba503dc40038c925047dfcf6f80ca8de2f0e20a6429d70267de3ada49
DIST gtk-gnutella-1.1.6.tar.bz2 19571757 SHA256 b755250f6b8af65b449f20e4dac77a677c1c3fd52f603dc9cd82b035740974c3 SHA512 ade3c8e8a776b4ff9351ad60b307f421f804c423811ea2bc7639656e3623fb95c1041c235578e07009c07f7c85911db72b9c17e04fca65a1661c8492c396069f WHIRLPOOL 857578452335885de3f918d54c663cd4d7beb1a3cad7970bf74f796866f3754c66d7a59e64bb2b1400eacb9413c47de51f29d41ef2178916a3cfd6d9e57294fe
+DIST gtk-gnutella-1.1.7.tar.bz2 19667586 SHA256 98ec6bacb0e275a95b35ee719314b3f65fe0fd813694829bd759e916050cf138 SHA512 2bb9ea6c70b62ac64dff8dd612292fddeca23075758258ea5259f408d26570ad2be34fdbb8b045e6e6f0238488386930c524dc2d0499327e02861e3837dfcbd4 WHIRLPOOL 6a935ca2c3a2b0d2ad19eb0e5952a50e47a7458f704d52eea66fb393849160d5cb5321217675dc97f032f85c67a97965af0ae9c1a0b2fab8e16b77966561e9df
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.1.7.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.7.ebuild
new file mode 100644
index 000000000000..154b509fd546
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-1.1.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ strip-linguas -i po
+
+ echo "# Gentoo-selected LINGUAS" > po/LINGUAS
+ for ling in ${LINGUAS}; do
+ echo $ling >> po/LINGUAS
+ done
+}
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_compile() {
+ # Build system is not parallel-safe, bug 500760
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}