summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gtorrentviewer')
-rw-r--r--net-p2p/gtorrentviewer/Manifest1
-rw-r--r--net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-curl-headers.patch12
-rw-r--r--net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch16
-rw-r--r--net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch14
-rw-r--r--net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild46
-rw-r--r--net-p2p/gtorrentviewer/metadata.xml8
6 files changed, 97 insertions, 0 deletions
diff --git a/net-p2p/gtorrentviewer/Manifest b/net-p2p/gtorrentviewer/Manifest
new file mode 100644
index 000000000000..08f39adfc8a0
--- /dev/null
+++ b/net-p2p/gtorrentviewer/Manifest
@@ -0,0 +1 @@
+DIST GTorrentViewer-0.2b.tar.gz 247584 SHA256 6e56351103f5d46a45be160baa1b7b956b4416fcdb4533b3d17a309665690c95 SHA512 4e8a0181d0492e9a88de09fe6399b9c6e4ca16913550b53597c00c2a413cd4c332b305b4b24735fa2b84bea87618ce7c22b111779f452a8d977470830d145b10 WHIRLPOOL 081245cbec27e98bf3931cd7fda06c275228028cb521eb67dbfcbdf003c7ebe88625a5addc4bba34b440babeeca1f2a0ae34b33702d593289dbe371d92d4175c
diff --git a/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-curl-headers.patch b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-curl-headers.patch
new file mode 100644
index 000000000000..66e33fb3932b
--- /dev/null
+++ b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-curl-headers.patch
@@ -0,0 +1,12 @@
+diff --git a/src/main.c b/src/main.c
+index fc51205..f46d30a 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -40,7 +40,6 @@
+ #include <errno.h>
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ #include "bencode.h"
diff --git a/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch
new file mode 100644
index 000000000000..8ddad12c3688
--- /dev/null
+++ b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-desktop.patch
@@ -0,0 +1,16 @@
+--- data/gtorrentviewer.desktop.in.old 2014-11-22 17:48:55.859683842 +0100
++++ data/gtorrentviewer.desktop.in 2014-11-22 17:49:25.400108137 +0100
+@@ -3,11 +3,9 @@
+ _GenericName=Torrent Viewer
+ _Comment=Viewer and Editor for .torrent files
+ Exec=gtorrentviewer %U
+-Icon=gtorrentviewer.png
++Icon=gtorrentviewer
+ StartupNotify=false
+ Terminal=false
+ Type=Application
+-Encoding=UTF-8
+-Categories=Application;Network;
++Categories=Network;
+ MimeType=application/x-bittorrent;
+-Version=0.2
diff --git a/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch
new file mode 100644
index 000000000000..22dd373e2967
--- /dev/null
+++ b/net-p2p/gtorrentviewer/files/gtorrentviewer-0.2b-underlinking.patch
@@ -0,0 +1,14 @@
+--- configure.ac
++++ configure.ac
+@@ -51,6 +51,11 @@
+ # Checks for libraries.
+ #
+
++dnl Check for libm for ceil()
++AC_SEARCH_LIBS([ceil], [m], [], [
++ AC_MSG_ERROR([unable to find the ceil() function])
++])
++
+ # check for libcurl.
+ AC_ARG_WITH([curl-config],
+ AC_HELP_STRING([--with-curl-config=PATH], [path to curl-config (e.g. /opt/bin)]),
diff --git a/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild b/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild
new file mode 100644
index 000000000000..825e26735d0e
--- /dev/null
+++ b/net-p2p/gtorrentviewer/gtorrentviewer-0.2b.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2
+
+MY_PN=${PN/gtorrentviewer/GTorrentViewer}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A GTK2-based viewer and editor for BitTorrent meta files"
+HOMEPAGE="http://gtorrentviewer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gtorrentviewer/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="
+ net-misc/curl
+ >=x11-libs/gtk+-2.4:2
+ >=dev-libs/glib-2.4:2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mv configure.in configure.ac || die #426262
+
+ epatch "${FILESDIR}"/${P}-curl-headers.patch
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ # Fix tests
+ echo "data/gtorrentviewer.desktop.in" >> po/POTFILES.in || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
diff --git a/net-p2p/gtorrentviewer/metadata.xml b/net-p2p/gtorrentviewer/metadata.xml
new file mode 100644
index 000000000000..a2e44fa192cb
--- /dev/null
+++ b/net-p2p/gtorrentviewer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="sourceforge">gtorrentviewer</remote-id>
+ </upstream>
+</pkgmetadata>