summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index b67c5a0b6b4c..0804614e8685 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,8 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit eutils python-r1 qt4-r2
DESCRIPTION="BitTorrent client in C++ and Qt"
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus debug +qt4 qt5 webui +X"
+IUSE="+dbus debug qt4 qt5 webui +X"
REQUIRED_USE="
^^ ( qt4 qt5 )
dbus? ( X )
@@ -70,13 +70,16 @@ src_configure() {
--with-qtsingleapplication=system
$(use dbus || echo --disable-qt-dbus)
$(use debug && echo --enable-debug)
- $(use qt5 && echo --with-qt5)
+ $(use qt4 && echo --with-qt4)
$(use webui || echo --disable-webui)
$(use X || echo --disable-gui)
)
- echo "${myconf[@]}"
"${myconf[@]}" || die "configure failed"
- use qt4 && eqmake4
- use qt5 && eqmake5
+
+ if use qt4 ;then
+ eqmake4
+ elif use qt5 ;then
+ eqmake5
+ fi
}