summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/syncthing')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.12.19.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 127d57363bf3..68a84f5d126c 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1 +1,2 @@
DIST syncthing-0.12.18.tar.gz 4046127 SHA256 e0d1af4f29c9e2325507a7daf4bf97098c87c321a7e075125b66ddaa34b37eb4 SHA512 2f2351a983b3d384e9fe65c87d67b81f20fc20b7b43b8d2fab882131bd4e4119f0cf099571d617f22f0125c43224c653e93329392204f3e0ff6c6a3bba7d8263 WHIRLPOOL cfe491241e9ef4ebd19042a3cc3188771cf64d67c0faa29feda7da5980f86a38c1e284938074271e25bbfb881eca1ca56f237bf81a61be4d836287cbfab27eb2
+DIST syncthing-0.12.19.tar.gz 4047476 SHA256 5a7035029974fe0fb496d9f8af880a50bcc8499ff5eef7ee4ef48f08df37820e SHA512 89d2b34c5bb9772bcaad84caa03794cdcfeade8fef0b8abaeea6a1cccdc09167a690aa8b1dfadac81d9ac0e8a07c9be112af7f2e56f12f589b906c518c49a686 WHIRLPOOL c0589a5e6a4f090dee9f79bb199c901b3f0e75cf0f92c12851a9713cdf7e813c8a5564ce475000529d2a5edafb9861d1b820858cb6fa3bb5bf082ff5586da9b3
diff --git a/net-p2p/syncthing/syncthing-0.12.19.ebuild b/net-p2p/syncthing/syncthing-0.12.19.ebuild
new file mode 100644
index 000000000000..07664310d1dc
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.12.19.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_PN="github.com/syncthing/syncthing"
+EGIT_COMMIT=v${PV}
+
+inherit golang-vcs-snapshot systemd
+
+DESCRIPTION="Syncthing is an open, trustworthy and decentralized cloud storage system"
+HOMEPAGE="http://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN}
+ go run build.go -version "v${PV}" -no-upgrade || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN}
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ cd src/${EGO_PN}
+ dobin bin/*
+ dodoc README.md AUTHORS CONTRIBUTING.md
+ systemd_dounit "${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}@.service
+ systemd_douserunit "${S}"/src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+}