summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/xmr-stak')
-rw-r--r--net-p2p/xmr-stak/Manifest1
-rw-r--r--net-p2p/xmr-stak/xmr-stak-2.8.0.ebuild67
-rw-r--r--net-p2p/xmr-stak/xmr-stak-9999.ebuild2
3 files changed, 69 insertions, 1 deletions
diff --git a/net-p2p/xmr-stak/Manifest b/net-p2p/xmr-stak/Manifest
index c93de1d64486..15d608e591fc 100644
--- a/net-p2p/xmr-stak/Manifest
+++ b/net-p2p/xmr-stak/Manifest
@@ -1,2 +1,3 @@
DIST xmr-stak-2.7.0.tar.gz 376873 BLAKE2B 78dd64acf7fbae46bf150d97b00c8443fbd097789b6e1aef99a954d966b8a75add358c82636621bb8b5639883a6d79b17ba3691e72354034bd944fa1f44d8c1e SHA512 cb56de595225ab22f1c53f1dd971898fcb14610a11d1cbc789e144a5b34f24e56f44fb75bdefc809bde17e434a5e6d02830874b9b825af179cd4699587f5e7c7
DIST xmr-stak-2.7.1.tar.gz 376919 BLAKE2B bdbd3f7ca522e200db072679f21ee79dc99167cf512f19008ca6b591d0c7ba73f58b68e0d2d7a2622cb88438922e28a4c78e4cbf9d617e28881cc37e1db8c08a SHA512 f33afa259ffde23bd0b5dd8efceadd98e4e176ccabbb68e79eb7cfcc88af9444e897c552e1eea2e3798291309847451ebfa1c44d5310e192014cf6b2aa5eb530
+DIST xmr-stak-2.8.0.tar.gz 388733 BLAKE2B cc75b2d80d7d9761b192f8d0752dde29d49c561675c63151f6cb915399dad715d133a17f2fa64c58ce8720a8de0a46bdb963c21571e29be3f99f0db3164aff40 SHA512 48803a9eb10e92763992dcbedb28b41735adf7da404312fe8358161cecef562bfc777a0b78ef90953db9c2a093adb30c4f9cd637f0613c949ff3b326662d2876
diff --git a/net-p2p/xmr-stak/xmr-stak-2.8.0.ebuild b/net-p2p/xmr-stak/xmr-stak-2.8.0.ebuild
new file mode 100644
index 000000000000..3244143bb5fe
--- /dev/null
+++ b/net-p2p/xmr-stak/xmr-stak-2.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/fireice-uk/xmr-stak.git"
+ EGIT_BRANCH="dev"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/fireice-uk/xmr-stak/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Unified all-in-one Monero miner"
+HOMEPAGE="https://github.com/fireice-uk/xmr-stak"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cuda devfee hwloc opencl ssl webserver"
+
+DEPEND="cuda? ( dev-util/nvidia-cuda-toolkit )
+ hwloc? ( sys-apps/hwloc )
+ opencl? ( virtual/opencl )
+ ssl? ( dev-libs/openssl:0= )
+ webserver? ( net-libs/libmicrohttpd )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ if ! use devfee; then
+ sed -i -e 's!fDevDonationLevel = .*;!fDevDonationLevel = 0.0;!' xmrstak/donate-level.hpp || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCUDA_ENABLE=$(usex cuda)
+ -DHWLOC_ENABLE=$(usex hwloc)
+ -DMICROHTTPD_ENABLE=$(usex webserver)
+ -DOpenCL_ENABLE=$(usex opencl)
+ -DOpenSSL_ENABLE=$(usex ssl)
+ -DLIBRARY_OUTPUT_PATH=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ systemd_newunit "${FILESDIR}"/${PN}-2.3.0.service ${PN}.service
+ doinitd "${FILESDIR}"/${PN}
+ dodir /etc/xmr-stak
+}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}etc/xmr-stak/main.config" ]; then
+ ewarn "To use xmr-stack:"
+ if use cuda || use opencl; then
+ ewarn "As root or as a user that is a member of the 'video' group,"
+ fi
+ ewarn "run:"
+ ewarn "/usr/bin/xmr-stak --cpu /etc/xmr-stak/cpu.config --amd /etc/xmr-stak/amd.config --nvidia /etc/xmr-stak/nvidia.config -c /etc/xmr-stak/main.config -C /etc/xmr-stak/pools.txt"
+ ewarn "xmr-stak can now be terminated and 'systemctl start xmr-stak' or '/etc/init.d/xmr-stak start' can be used."
+ fi
+}
diff --git a/net-p2p/xmr-stak/xmr-stak-9999.ebuild b/net-p2p/xmr-stak/xmr-stak-9999.ebuild
index 8a521d6793d7..b0edfc7d2166 100644
--- a/net-p2p/xmr-stak/xmr-stak-9999.ebuild
+++ b/net-p2p/xmr-stak/xmr-stak-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils systemd