summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/i2p/Manifest2
-rw-r--r--net-p2p/i2p/i2p-0.9.22-r1.ebuild106
-rw-r--r--net-p2p/i2p/i2p-0.9.22.ebuild103
-rw-r--r--net-p2p/i2p/i2p-0.9.23.ebuild122
-rw-r--r--net-p2p/i2p/i2p-0.9.24.ebuild133
5 files changed, 0 insertions, 466 deletions
diff --git a/net-p2p/i2p/Manifest b/net-p2p/i2p/Manifest
index c2dfc5b30a92..1504c9cc1987 100644
--- a/net-p2p/i2p/Manifest
+++ b/net-p2p/i2p/Manifest
@@ -1,4 +1,2 @@
-DIST i2psource_0.9.22.tar.bz2 24338146 SHA256 91ac91f7a3e202d248f5294f4951f6b7d8b9bde32991adf7a813ae1bb9188898 SHA512 0fdcd0369f79cc143c449774cb205d2fb4fa5ad32e0b5bd3ed0dee5b24402cc21b1c5650d535518e68aaa98cee5380bf0af041df8b3e1724698aebf61cfb5583 WHIRLPOOL bd36ce760f7a7b942651de576662b3fadbf19bbdb84a020a16783689f3ae4919bf9441762f2d951ed1c02781e62131370b5cc36cd257c187185862901454e971
-DIST i2psource_0.9.23.tar.bz2 24427211 SHA256 24e303f2af1b7b14ed3a6e17cc7d1b6432ec99d8d00246a88486922941c72345 SHA512 1697ee03c5b09c7653f4e30e976062908e0c0ece7ee9651979384fce0d5c887d7cfbd841522d31203f23d7f5dc97d8f8ef238784199b22fe5452299587038f82 WHIRLPOOL a2141b8d9d5f8b552e354678294364bedde9cef5aa39aa95a06dbe19f5f7996b6d5eb0e1b43ad8ce5c2f9e20dc4dda792b994004a95ea1dc83c5541f46de5b89
DIST i2psource_0.9.24.tar.bz2 24468215 SHA256 134481ae5ef934a411545330d1b22e768189c424a65db47058db0f7d9cf51e7d SHA512 9029ea06640a937385499fd308232f2c3b04308cc834e2e2491a567c47be4aa128d509b2058735cb8cf088a0b9273b418efbca05d70944ef9e95c3d15d96a47a WHIRLPOOL d7211cf46bf4bbaa54340de0dadcb255f2321d75b3d968401612c1bc0926f91f1d248e634c97c8d6948f78cd4a68c9a79ca4a65102e205a56c704a2409416cf3
DIST i2psource_0.9.25.tar.bz2 24652935 SHA256 daaac2b5a5a6b5bbd4b805f76e14f6a7c201dfd7c1cf43c98e182d2e657d1236 SHA512 a50f00d9ad32993da30529339e3ffd425d5e97d5120d9e4e446f6fa7ac0cbb6ee4f35c013b0815802ff6c72e188b00d408c7fa398c8ee1ae71be57383a1411f6 WHIRLPOOL a851f6505155201d872774407dc71c9dd03a4683b3ce35d2fff74fd3f7f17d12cc1cc72dfcc2c7c4f0d82b86333bd0424066ae41330e603ba07872d56c257e27
diff --git a/net-p2p/i2p/i2p-0.9.22-r1.ebuild b/net-p2p/i2p/i2p-0.9.22-r1.ebuild
deleted file mode 100644
index c1b1f028a529..000000000000
--- a/net-p2p/i2p/i2p-0.9.22-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils java-pkg-2 java-ant-2 systemd user
-
-DESCRIPTION="A privacy-centric, anonymous network."
-HOMEPAGE="https://geti2p.net"
-SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
-
-LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
-SLOT="0"
-
-# Until the deps reach other arches
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-# dev-java/ant-core is automatically added due to java-ant-2.eclass
-CDEPEND="dev-java/jrobin:0
- dev-java/bcprov:1.50
- dev-java/slf4j-api:0
- dev-java/tomcat-jstl-impl:0
- dev-java/tomcat-jstl-spec:0
- dev-java/java-service-wrapper:0"
-
-DEPEND="${CDEPEND}
- dev-java/eclipse-ecj:*
- dev-libs/gmp:*
- nls? ( sys-devel/gettext )
- >=virtual/jdk-1.6"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-EANT_BUILD_TARGET="pkg"
-EANT_GENTOO_CLASSPATH="java-service-wrapper,jrobin,slf4j-api,tomcat-jstl-impl,tomcat-jstl-spec,bcprov-1.50"
-
-pkg_setup() {
- enewgroup i2p
- enewuser i2p -1 -1 /var/lib/i2p i2p -m
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- java-ant_rewrite-classpath
-}
-
-src_prepare() {
- # We're on GNU/Linux, we don't need .exe files
- echo "noExe=true" > override.properties
- if ! use nls; then
- echo "require.gettext=false" >> override.properties
- fi
-}
-
-src_install() {
- # Cd into pkg-temp.
- cd "${S}/pkg-temp" || die
-
- # Apply patch.
- epatch "${FILESDIR}/${P}_fix-paths.patch"
-
- # Using ${D} here results in an error. Docs say use $ROOT
- i2p_home="${ROOT}/usr/share/i2p"
-
- # This is ugly, but to satisfy all non-system .jar dependencies, jetty and
- # systray4j would need to be packaged. The former would be too large a task
- # for an unseasoned developer and systray4j hasn't been touched in over 10
- # years. This seems to be the most pragmatic solution
- java-pkg_jarinto "${i2p_home}/lib"
- for i in BOB commons-el commons-logging i2p i2psnark i2ptunnel \
- jasper-compiler jasper-runtime javax.servlet jbigi jetty* mstreaming org.mortbay.* router* \
- sam standard streaming systray systray4j; do
- java-pkg_dojar lib/${i}.jar
- done
-
- # Set up symlinks for binaries
- dosym /usr/bin/wrapper ${i2p_home}/i2psvc
- dosym ${i2p_home}/i2prouter /usr/bin/i2prouter
- dosym ${i2p_home}/eepget /usr/bin/eepget
-
- # Install main files and basic documentation
- exeinto ${i2p_home}
- insinto ${i2p_home}
- doins blocklist.txt hosts.txt *.config
- doexe eepget i2prouter runplain.sh
- dodoc history.txt INSTALL-headless.txt LICENSE.txt
- doman man/*
-
- # Install other directories
- doins -r certificates docs eepsite geoip scripts
- dodoc -r licenses
- java-pkg_dowar webapps/*.war
-
- # Install daemon files
- newinitd "${FILESDIR}/i2p.initd" i2p
- systemd_newunit "${FILESDIR}"/i2p.service i2p.service
-}
-
-pkg_postinst() {
- elog "Custom configuration belongs in /var/lib/i2p/.i2p/ to avoid being overwritten."
- elog "I2P can be configured through the web interface at http://localhost:7657/index.jsp"
-}
diff --git a/net-p2p/i2p/i2p-0.9.22.ebuild b/net-p2p/i2p/i2p-0.9.22.ebuild
deleted file mode 100644
index 879f6320e1ce..000000000000
--- a/net-p2p/i2p/i2p-0.9.22.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils java-pkg-2 java-ant-2 systemd user
-
-DESCRIPTION="A privacy-centric, anonymous network."
-HOMEPAGE="https://geti2p.net"
-SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
-
-LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
-SLOT="0"
-
-# Until the deps reach other arches
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-# dev-java/ant-core is automatically added due to java-ant-2.eclass
-CDEPEND="dev-java/jrobin:0
- dev-java/slf4j-api:0
- dev-java/java-service-wrapper:0"
-
-DEPEND="${CDEPEND}
- dev-java/eclipse-ecj:*
- dev-libs/gmp:*
- nls? ( sys-devel/gettext )
- >=virtual/jdk-1.6"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-EANT_BUILD_TARGET="pkg"
-EANT_GENTOO_CLASSPATH="java-service-wrapper,jrobin,slf4j-api"
-
-pkg_setup() {
- enewgroup i2p
- enewuser i2p -1 -1 /var/lib/i2p i2p -m
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- java-ant_rewrite-classpath
-}
-
-src_prepare() {
- # We're on GNU/Linux, we don't need .exe files
- echo "noExe=true" > override.properties
- if ! use nls; then
- echo "require.gettext=false" >> override.properties
- fi
-}
-
-src_install() {
- # Cd into pkg-temp.
- cd "${S}/pkg-temp" || die
-
- # Apply patch.
- epatch "${FILESDIR}/${P}_fix-paths.patch"
-
- # Using ${D} here results in an error. Docs say use $ROOT
- i2p_home="${ROOT}/usr/share/i2p"
-
- # This is ugly, but to satisfy all non-system .jar dependencies, jetty and
- # systray4j would need to be packaged. The former would be too large a task
- # for an unseasoned developer and systray4j hasn't been touched in over 10
- # years. This seems to be the most pragmatic solution
- java-pkg_jarinto "${i2p_home}/lib"
- for i in BOB commons-el commons-logging i2p i2psnark i2ptunnel \
- jasper-compiler jasper-runtime javax.servlet jbigi jetty* mstreaming org.mortbay.* router* \
- sam standard streaming systray systray4j; do
- java-pkg_dojar lib/${i}.jar
- done
-
- # Set up symlinks for binaries
- dosym /usr/bin/wrapper ${i2p_home}/i2psvc
- dosym ${i2p_home}/i2prouter /usr/bin/i2prouter
- dosym ${i2p_home}/eepget /usr/bin/eepget
-
- # Install main files and basic documentation
- exeinto ${i2p_home}
- insinto ${i2p_home}
- #doins blocklist.txt hosts.txt *.config
- doexe eepget i2prouter runplain.sh
- dodoc history.txt INSTALL-headless.txt LICENSE.txt
- doman man/*
-
- # Install other directories
- doins -r certificates docs eepsite geoip scripts
- dodoc -r licenses
- java-pkg_dowar webapps/*.war
-
- # Install daemon files
- newinitd "${FILESDIR}/i2p.initd" i2p
- systemd_newunit "${FILESDIR}"/i2p.service i2p.service
-}
-
-pkg_postinst() {
- elog "Custom configuration belongs in /var/lib/i2p/.i2p/ to avoid being overwritten."
- elog "I2P can be configured through the web interface at http://localhost:7657/index.jsp"
-}
diff --git a/net-p2p/i2p/i2p-0.9.23.ebuild b/net-p2p/i2p/i2p-0.9.23.ebuild
deleted file mode 100644
index bfe7595503bd..000000000000
--- a/net-p2p/i2p/i2p-0.9.23.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils java-pkg-2 java-ant-2 systemd user
-
-DESCRIPTION="A privacy-centric, anonymous network."
-HOMEPAGE="https://geti2p.net"
-SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
-
-LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
-SLOT="0"
-
-# Until the deps reach other arches
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-# dev-java/ant-core is automatically added due to java-ant-2.eclass
-CDEPEND="dev-java/jrobin:0
- dev-java/bcprov:1.50
- dev-java/slf4j-api:0
- dev-java/tomcat-jstl-impl:0
- dev-java/tomcat-jstl-spec:0
- dev-java/java-service-wrapper:0"
-
-DEPEND="${CDEPEND}
- dev-java/eclipse-ecj:*
- dev-libs/gmp:*
- nls? ( sys-devel/gettext )
- >=virtual/jdk-1.6"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-EANT_BUILD_TARGET="pkg"
-EANT_GENTOO_CLASSPATH="java-service-wrapper,jrobin,slf4j-api,tomcat-jstl-impl,tomcat-jstl-spec,bcprov-1.50"
-
-pkg_setup() {
- java-pkg-2_pkg_setup
-
- enewgroup i2p
- enewuser i2p -1 -1 /var/lib/i2p i2p -m
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die
- java-ant_rewrite-classpath
-}
-
-src_prepare() {
- java-pkg-2_src_prepare
-
- # We're on GNU/Linux, we don't need .exe files
- echo "noExe=true" > override.properties
- if ! use nls; then
- echo "require.gettext=false" >> override.properties
- fi
-
- #epatch "${FILESDIR}/${P}_fix-encoding.patch"
-}
-
-src_install() {
- # Cd into pkg-temp.
- cd "${S}/pkg-temp" || die
-
- # Apply patch.
- epatch "${FILESDIR}/${P}_fix-paths.patch"
-
- # Using ${D} here results in an error. Docs say use $ROOT
- i2p_home="${ROOT}/usr/share/i2p"
-
- # This is ugly, but to satisfy all non-system .jar dependencies, jetty and
- # systray4j would need to be packaged. The former would be too large a task
- # for an unseasoned developer and systray4j hasn't been touched in over 10
- # years. This seems to be the most pragmatic solution
- java-pkg_jarinto "${i2p_home}/lib"
- for i in BOB commons-el commons-logging i2p i2psnark i2ptunnel \
- jasper-compiler jasper-runtime javax.servlet jbigi jetty* mstreaming org.mortbay.* router* \
- sam standard streaming systray systray4j; do
- java-pkg_dojar lib/${i}.jar
- done
-
- # Set up symlinks for binaries
- dosym /usr/bin/wrapper ${i2p_home}/i2psvc
- dosym ${i2p_home}/i2prouter /usr/bin/i2prouter
- dosym ${i2p_home}/eepget /usr/bin/eepget
-
- # Install main files and basic documentation
- exeinto ${i2p_home}
- insinto ${i2p_home}
- doins blocklist.txt hosts.txt *.config
- doexe eepget i2prouter runplain.sh
- dodoc history.txt INSTALL-headless.txt LICENSE.txt
- doman man/*
-
- # Install other directories
- doins -r certificates docs eepsite geoip scripts
- dodoc -r licenses
- java-pkg_dowar webapps/*.war
-
- # Install daemon files
- newinitd "${FILESDIR}/${P}_initd" i2p
- systemd_newunit "${FILESDIR}"/i2p.service i2p.service
-
- # setup user
- dodir /var/lib/i2p/.i2p
- fowners -R i2p:i2p /var/lib/i2p/.i2p
-}
-
-pkg_postinst() {
- elog "Custom configuration belongs in /var/lib/i2p/.i2p/ to avoid being overwritten."
- elog "I2P can be configured through the web interface at http://localhost:7657/index.jsp"
-
- ewarn 'Currently, the i2p team do not enforce to use ECDSA keys. But it is more and'
- ewarn 'more pushed. To help the network, you are recommended to have either:'
- ewarn ' dev-java/icedtea[-sunec,nss]'
- ewarn ' dev-java/oracle-jre-bin'
- ewarn ' dev-java/oracle-jdk-bin'
-}
diff --git a/net-p2p/i2p/i2p-0.9.24.ebuild b/net-p2p/i2p/i2p-0.9.24.ebuild
deleted file mode 100644
index dd695e9894ca..000000000000
--- a/net-p2p/i2p/i2p-0.9.24.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils java-pkg-2 java-ant-2 systemd user
-
-DESCRIPTION="A privacy-centric, anonymous network."
-HOMEPAGE="https://geti2p.net"
-SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
-
-LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
-SLOT="0"
-
-# Until the deps reach other arches
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-# dev-java/ant-core is automatically added due to java-ant-2.eclass
-CDEPEND="dev-java/jrobin:0
- dev-java/bcprov:1.50
- dev-java/slf4j-api:0
- dev-java/tomcat-jstl-impl:0
- dev-java/tomcat-jstl-spec:0
- dev-java/java-service-wrapper:0"
-
-DEPEND="${CDEPEND}
- dev-java/eclipse-ecj:*
- dev-libs/gmp:*
- nls? ( sys-devel/gettext )
- >=virtual/jdk-1.7"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.7"
-
-EANT_BUILD_TARGET="pkg"
-EANT_GENTOO_CLASSPATH="java-service-wrapper,jrobin,slf4j-api,tomcat-jstl-impl,tomcat-jstl-spec,bcprov-1.50"
-
-I2P_ROOT='/usr/share/i2p'
-I2P_CONFIG_HOME='/var/lib/i2p'
-I2P_CONFIG_DIR="${I2P_HOME}/.i2p"
-
-pkg_setup() {
- java-pkg-2_pkg_setup
-
- enewgroup i2p
- enewuser i2p -1 -1 "${I2P_CONFIG_HOME}" i2p -m
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}" || die
- java-ant_rewrite-classpath
-}
-
-src_prepare() {
- java-pkg-2_src_prepare
-
- # We're on GNU/Linux, we don't need .exe files
- echo "noExe=true" > override.properties
- if ! use nls; then
- echo "require.gettext=false" >> override.properties
- fi
-}
-
-src_install() {
- # Cd into pkg-temp.
- cd "${S}/pkg-temp" || die
-
- # add libs
- epatch "${FILESDIR}/${P}_add-libs.patch"
-
- # avoid auto starting browser
- sed -i 's|clientApp.4.startOnLoad=true|clientApp.4.startOnLoad=false|' \
- clients.config || die
-
- # replace paths as the installer would
- sed -i "s|%INSTALL_PATH|${I2P_ROOT}|" \
- eepget i2prouter runplain.sh || die
- sed -i "s|\$INSTALL_PATH|${I2P_ROOT}|" wrapper.config || die
- sed -i "s|%SYSTEM_java_io_tmpdir|${I2P_CONFIG_DIR}|" \
- i2prouter runplain.sh || die
- sed -i "s|%USER_HOME|${I2P_CONFIG_HOME}|" i2prouter || die
-
- # This is ugly, but to satisfy all non-system .jar dependencies, jetty and
- # systray4j would need to be packaged. The former would be too large a task
- # for an unseasoned developer and systray4j hasn't been touched in over 10
- # years. This seems to be the most pragmatic solution
- java-pkg_jarinto "${I2P_ROOT}/lib"
- for i in BOB commons-el commons-logging i2p i2psnark i2ptunnel \
- jasper-compiler jasper-runtime javax.servlet jbigi jetty* mstreaming org.mortbay.* router* \
- sam standard streaming systray systray4j; do
- java-pkg_dojar lib/${i}.jar
- done
-
- # Set up symlinks for binaries
- dosym /usr/bin/wrapper "${I2P_ROOT}/i2psvc"
- dosym "${I2P_ROOT}/i2prouter" /usr/bin/i2prouter
- dosym "${I2P_ROOT}/eepget" /usr/bin/eepget
-
- # Install main files and basic documentation
- exeinto "${I2P_ROOT}"
- insinto "${I2P_ROOT}"
- doins blocklist.txt hosts.txt *.config
- doexe eepget i2prouter runplain.sh
- dodoc history.txt INSTALL-headless.txt LICENSE.txt
- doman man/*
-
- # Install other directories
- doins -r certificates docs eepsite geoip scripts
- dodoc -r licenses
- java-pkg_dowar webapps/*.war
-
- # Install daemon files
- newinitd "${FILESDIR}/${P}_initd" i2p
- systemd_newunit "${FILESDIR}"/i2p.service i2p.service
-
- # setup user
- dodir "${I2P_CONFIG_DIR}"
- fowners -R i2p:i2p "${I2P_CONFIG_DIR}"
-}
-
-pkg_postinst() {
- elog "Custom configuration belongs in /var/lib/i2p/.i2p/ to avoid being overwritten."
- elog "I2P can be configured through the web interface at http://localhost:7657/index.jsp"
-
- ewarn 'Currently, the i2p team do not enforce to use ECDSA keys. But it is more and'
- ewarn 'more pushed. To help the network, you are recommended to have either:'
- ewarn ' dev-java/icedtea[-sunec,nss]'
- ewarn ' dev-java/oracle-jre-bin'
- ewarn ' dev-java/oracle-jdk-bin'
-}