summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/libinklevel/libinklevel-0.9.3.ebuild')
-rw-r--r--net-print/libinklevel/libinklevel-0.9.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-print/libinklevel/libinklevel-0.9.3.ebuild b/net-print/libinklevel/libinklevel-0.9.3.ebuild
new file mode 100644
index 000000000000..384eec93be7e
--- /dev/null
+++ b/net-print/libinklevel/libinklevel-0.9.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/_/}"
+DESCRIPTION="A library to get the ink level of your printer"
+HOMEPAGE="http://libinklevel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libinklevel/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libieee1284-0.2.11
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.2-autoconf-2.70.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "/^dist_doc_DATA/d" Makefile.am \
+ || die "Failed to disable installation of docs"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}