summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.0.0.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.0.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-proxy/haproxy/haproxy-2.0.0.ebuild b/net-proxy/haproxy/haproxy-2.0.0.ebuild
index e41593121e88..3924975aade7 100644
--- a/net-proxy/haproxy/haproxy-2.0.0.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.0.ebuild
@@ -20,8 +20,8 @@ fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="+crypt doc examples libressl slz +net_ns +pcre pcre-jit pcre2 pcre2-jit ssl
-systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
+IUSE="+crypt doc examples libressl slz +net_ns +pcre pcre-jit pcre2 pcre2-jit prometheus-exporter
+ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
@@ -98,8 +98,12 @@ src_compile() {
# For now, until the strict-aliasing breakage will be fixed
append-cflags -fno-strict-aliasing
+ if use prometheus-exporter; then
+ EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
+ fi
+
# HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
- emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
+ emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
emake -C contrib/systemd SBINDIR=/usr/sbin
if use tools ; then