summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.0.14-r1.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.0.14-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild b/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
index 7e2cb38725c6..d1c45681b560 100644
--- a/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
@@ -97,12 +97,17 @@ src_compile() {
# For now, until the strict-aliasing breakage will be fixed
append-cflags -fno-strict-aliasing
+ # Bug #668002
+ if use ppc || use arm || use hppa; then
+ TARGET_LDFLAGS=-latomic
+ fi
+
if use prometheus-exporter; then
EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
fi
# HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
- emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
+ emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
emake -C contrib/systemd SBINDIR=/usr/sbin
if use tools ; then