summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/Manifest1
-rw-r--r--net-proxy/haproxy/haproxy-1.8.30-r1.ebuild175
2 files changed, 0 insertions, 176 deletions
diff --git a/net-proxy/haproxy/Manifest b/net-proxy/haproxy/Manifest
index a37f218ce372..ebd459f87218 100644
--- a/net-proxy/haproxy/Manifest
+++ b/net-proxy/haproxy/Manifest
@@ -1,4 +1,3 @@
-DIST haproxy-1.8.30.tar.gz 2214184 BLAKE2B 07378b61c0b103fe3ff4c4ab936960d2f709cd20833ce2c343dece5496997f6819c68d0a58c6e11e4020b9a551328f9522b0ab739e7a0acd549eaa883bff7401 SHA512 13b0f80ad08c8d3ae41114b8112acd4f80f1f173f1a91a5f65439be86f341653be43ce9fe69168a934ccdb7a24abf476aef097b1f8fec5a0577f72ef19486d1f
DIST haproxy-2.0.14.tar.gz 2651320 BLAKE2B dd5aed78e52b3d3dd295f3883d45adf8795efac93cf6c23fbe39be031f29d19adad0afb400e8041281413f4570bc074f06d9cd88bee672789311e56f57b258d0 SHA512 6b63b713a1009eff59a2622fa93462deb8794c910685840f142711a61be88ea228c7cb2ec7ca50bba0803288625e1a65b2d2f87ffbcedfd23debfbbbb5d96993
DIST haproxy-2.0.22.tar.gz 2698262 BLAKE2B 417bc6bdfad276d210d597896f0685637034593a2418b0fcf984e62b767a491000a1f62f58b5ccc8f552890de14607737bc81bdf4736b6e4212ac15081ef5689 SHA512 29a1ee6d77892003ab4d813336d1ea165d91784bcf2124b98ca030e376e7ccc1c1b9f09e9a85ef0cd04f9808b589bfc7b7c19f831dcb55bb41d7777a172112ff
DIST haproxy-2.0.23.tar.gz 2704381 BLAKE2B dbdad6bb11470088cae0092b4f0cef38840e2166f31e1fe2d571515ebd12c234a1470e7e59c07a68ab95f664deb15a1df537f405ffc800d89b0261fe5cb644f0 SHA512 0ede44b4d33630ac2d4419c93333aeb95c3cdc24f2aa0438a7e7fe57b4063fd91e308f974f29efdbfe62f24bc051c742645b48f3a810befc315ea54f1ada37dc
diff --git a/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild b/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild
deleted file mode 100644
index e6b1932baf9b..000000000000
--- a/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild
+++ /dev/null
@@ -1,175 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-LUA_COMPAT=( lua5-3 )
-
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
-
-MY_P="${PN}-${PV/_beta/-dev}"
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://www.haproxy.org"
-if [[ ${PV} != *9999 ]]; then
- SRC_URI="http://haproxy.1wt.eu/download/$(ver_cut 1-2)/src/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
-else
- EGIT_REPO_URI="http://git.haproxy.org/git/haproxy-$(ver_cut 1-2).git/"
- EGIT_BRANCH=master
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="+crypt doc examples slz net_ns +pcre pcre-jit pcre2 pcre2-jit ssl
-systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
-REQUIRED_USE="pcre-jit? ( pcre )
- pcre2-jit? ( pcre2 )
- pcre? ( !pcre2 )
- lua? ( ${LUA_REQUIRED_USE} )
- device-atlas? ( pcre )
- ?? ( slz zlib )"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="
- crypt? ( virtual/libcrypt:= )
- pcre? (
- dev-libs/libpcre
- pcre-jit? ( dev-libs/libpcre[jit] )
- )
- pcre2? (
- dev-libs/libpcre2:=
- pcre2-jit? ( dev-libs/libpcre2:=[jit] )
- )
- ssl? (
- dev-libs/openssl:0=[zlib?]
- )
- slz? ( dev-libs/libslz:= )
- systemd? ( sys-apps/systemd )
- zlib? ( sys-libs/zlib )
- lua? ( ${LUA_DEPS} )
- device-atlas? ( dev-libs/device-atlas-api-c )"
-RDEPEND="${DEPEND}
- acct-group/haproxy
- acct-user/haproxy"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS README )
-CONTRIBS=( halog iprange )
-# ip6range is present in 1.6, but broken.
-ver_test ${PV} -ge 1.7.0 && CONTRIBS+=( ip6range spoa_example tcploop )
-# TODO: mod_defender - requires apache / APR, modsecurity - the same
-ver_test ${PV} -ge 1.8.0 && CONTRIBS+=( hpack )
-
-haproxy_use() {
- (( $# != 2 )) && die "${FUNCNAME} <USE flag> <make option>"
-
- usex "${1}" "USE_${2}=1" "USE_${2}="
-}
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
- if use net_ns; then
- CONFIG_CHECK="~NET_NS"
- linux-info_pkg_setup
- fi
-}
-
-src_compile() {
- local -a args=(
- V=1
- TARGET=linux2628
- USE_GETADDRINFO=1
- USE_TFO=1
- )
-
- # TODO: PCRE2_WIDTH?
- args+=( $(haproxy_use threads THREAD) )
- args+=( $(haproxy_use crypt LIBCRYPT) )
- args+=( $(haproxy_use net_ns NS) )
- args+=( $(haproxy_use pcre PCRE) )
- args+=( $(haproxy_use pcre-jit PCRE_JIT) )
- args+=( $(haproxy_use ssl OPENSSL) )
- args+=( $(haproxy_use slz SLZ) )
- args+=( $(haproxy_use zlib ZLIB) )
- args+=( $(haproxy_use lua LUA) )
- args+=( $(haproxy_use 51degrees 51DEGREES) )
- args+=( $(haproxy_use device-atlas DEVICEATLAS) )
- args+=( $(haproxy_use wurfl WURFL) )
- args+=( $(haproxy_use systemd SYSTEMD) )
-
- # For now, until the strict-aliasing breakage will be fixed
- append-cflags -fno-strict-aliasing
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
- emake -C contrib/systemd SBINDIR=/usr/sbin
-
- if use tools ; then
- for contrib in ${CONTRIBS[@]} ; do
- emake -C contrib/${contrib} \
- CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
- done
- fi
-}
-
-src_install() {
- dosbin haproxy
- dosym ../sbin/haproxy /usr/bin/haproxy
-
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
- newinitd "${FILESDIR}/${PN}.initd-r6" ${PN}
-
- doman doc/haproxy.1
-
- systemd_dounit contrib/systemd/haproxy.service
-
- einstalldocs
-
- # The errorfiles are used by upstream defaults.
- insinto /etc/haproxy/errors/
- doins examples/errorfiles/*
-
- if use doc; then
- dodoc ROADMAP doc/*.txt
- #if use lua; then
- # TODO: doc/lua-api/
- #fi
- fi
-
- if use tools ; then
- has halog "${CONTRIBS[@]}" && dobin contrib/halog/halog
- has "iprange" "${CONTRIBS[@]}" && newbin contrib/iprange/iprange haproxy_iprange
- has "ip6range" "${CONTRIBS[@]}" && newbin contrib/ip6range/ip6range haproxy_ip6range
- has "spoa_example" "${CONTRIBS[@]}" && newbin contrib/spoa_example/spoa haproxy_spoa_example
- has "spoa_example" "${CONTRIBS[@]}" && newdoc contrib/spoa_example/README README.spoa_example
- has "tcploop" "${CONTRIBS[@]}" && newbin contrib/tcploop/tcploop haproxy_tcploop
- has "hpack" "${CONTRIBS[@]}" && newbin contrib/hpack/gen-rht haproxy_hpack
- fi
-
- if use examples ; then
- docinto examples
- dodoc examples/*.cfg
- dodoc examples/seamless_reload.txt
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${EROOT}/etc/haproxy/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${EROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${EROOT}/usr/share/doc/${PF}"
- fi
- fi
-}