summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild b/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild
new file mode 100644
index 000000000000..73eead3504b4
--- /dev/null
+++ b/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
+HOMEPAGE="http://www.wolfermann.org/dnsproxy.html"
+SRC_URI="http://www.wolfermann.org/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}"/${P}-include.patch
+ append-cppflags -D_GNU_SOURCE
+
+ default
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ dosbin ${PN}
+ keepdir /var/empty
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ insinto /etc/${PN}
+ newins ${PN}.conf ${PN}.conf.dist
+
+ dodoc README
+ doman ${PN}.1
+}