summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/telepathy-haze/telepathy-haze-0.8.0.ebuild')
-rw-r--r--net-voip/telepathy-haze/telepathy-haze-0.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-voip/telepathy-haze/telepathy-haze-0.8.0.ebuild b/net-voip/telepathy-haze/telepathy-haze-0.8.0.ebuild
new file mode 100644
index 000000000000..967afd41a925
--- /dev/null
+++ b/net-voip/telepathy-haze/telepathy-haze-0.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Telepathy connection manager providing libpurple supported protocols"
+HOMEPAGE="http://developer.pidgin.im/wiki/TelepathyHaze"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+#IUSE="test"
+IUSE=""
+
+# Tests failing, see upstream: https://bugs.freedesktop.org/34577
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ >=net-im/pidgin-2.7
+ >=net-libs/telepathy-glib-0.15.1[${PYTHON_USEDEP}]
+ >=dev-libs/glib-2.30:2
+ >=dev-libs/dbus-glib-0.73
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? ( dev-python/twisted-words )"