summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-gabble/files/telepathy-gabble-0.18.4-build-fix-no-jingle.patch29
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.18.4.ebuild9
2 files changed, 37 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/files/telepathy-gabble-0.18.4-build-fix-no-jingle.patch b/net-voip/telepathy-gabble/files/telepathy-gabble-0.18.4-build-fix-no-jingle.patch
new file mode 100644
index 000000000000..6d25cde8f527
--- /dev/null
+++ b/net-voip/telepathy-gabble/files/telepathy-gabble-0.18.4-build-fix-no-jingle.patch
@@ -0,0 +1,29 @@
+From 8801beb5b64952fad15ff0c316bf1eddbde20ba9 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 2 Sep 2017 18:23:10 +0200
+Subject: [PATCH] Add missing VOIP ifdef guards
+
+Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=523230
+---
+ src/muc-channel.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/muc-channel.c b/src/muc-channel.c
+index c0a27a490..9f6e01167 100644
+--- a/src/muc-channel.c
++++ b/src/muc-channel.c
+@@ -1647,9 +1647,11 @@ gabble_muc_channel_can_be_closed (GabbleMucChannel *chan)
+ if (g_hash_table_size (priv->tubes) > 0)
+ return FALSE;
+
++#ifdef ENABLE_VOIP
+ if (priv->calls != NULL || priv->call_requests != NULL
+ || priv->call_initiating)
+ return FALSE;
++#endif
+
+ return TRUE;
+ }
+--
+2.14.1
+
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.18.4.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.18.4.ebuild
index d9f8cb96c3c8..434def47dfbf 100644
--- a/net-voip/telepathy-gabble/telepathy-gabble-0.18.4.ebuild
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.18.4.ebuild
@@ -44,7 +44,9 @@ RDEPEND="
DEPEND="${RDEPEND}
${PYTHON_DEPS}
>=dev-util/gtk-doc-am-1.17
- dev-libs/libxslt"
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
# Twisted tests fail if bad ipv6 setup, upstream bug #30565
# Random twisted tests fail with org.freedesktop.DBus.Error.NoReply for some reason
# pygobject:2 is needed by twisted-17 for gtk2reactor usage by gabble
@@ -58,6 +60,11 @@ DEPEND="${RDEPEND}
# ) )
#)
+PATCHES=(
+ # Fix build with USE=-jingle, bug #523230
+ "${FILESDIR}"/${P}-build-fix-no-jingle.patch
+)
+
pkg_setup() {
python-any-r1_pkg_setup
}