summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/tinc')
-rw-r--r--net-vpn/tinc/Manifest1
-rw-r--r--net-vpn/tinc/tinc-1.0.35.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-vpn/tinc/Manifest b/net-vpn/tinc/Manifest
index a6f95f0a4014..14650b1eb641 100644
--- a/net-vpn/tinc/Manifest
+++ b/net-vpn/tinc/Manifest
@@ -1,3 +1,4 @@
DIST tinc-1.0.33.tar.gz 486374 BLAKE2B 542e9c95aa3dea941315c5a3293c06137be7131bbb4a3ba5d788e7c250327d0b01530db5b3371aee85b1e85a104b9997e9f09a6b33051090da087595e1bcb9da SHA512 f17c7682e177d85a049891255fc590069c7901307951ee93364a7a754f1a7c5ca4b6a6f7ddcb4c9ad150f0155ff7db7112990a3fc3a6496b48bdbfd3b1ae8804
DIST tinc-1.0.34.tar.gz 484174 BLAKE2B 8ba80983cb1293b03b814f305bd733a2208562b8450a539c0f80c25596c0e05fb7ebc8edf8e6617b9e18d8b96bb49a82098f902e692ce4b85c7c47b1072be2dd SHA512 b711a2c532f8efc94c77e9bbe5213ae284d2a3cb598d2760df700448e495a02ac56baa0393bbc6fbc735bf97a26ca5a79133c92952d98a9086a9ffd273eef725
+DIST tinc-1.0.35.tar.gz 499277 BLAKE2B 419b581167614d534b6f2f3b804657f088c013529d7738766aff199da775860ffed42ecb61e8ed008c5b6fa410f071e2fe1ca59f0c6e443c0a8017cd10c31ce3 SHA512 037867306c21506d57d69d35c0f246b2936022047978fa3e01464b5f6b65f109760507d9cc740f82f8166f39c5ce44d9f8dde55655a6372dacd5b5974aeaee32
DIST tinc-1.1pre16.tar.gz 703679 BLAKE2B c02636f52983c1fdebe28058a5e49f3952ac10b238c9d8f01a10b140960803f197a057c883860ca259b949883c406cf74f518d0e45bf84f10566a964570daf9b SHA512 b32a0a734a4c8a91bad4cef4177cb45757c97c09dc179da1e3357f2fde48b3b0747587dbac31ecb5400e1553b6712d474a6a1808ac24bce1a3494c1842bb6c43
diff --git a/net-vpn/tinc/tinc-1.0.35.ebuild b/net-vpn/tinc/tinc-1.0.35.ebuild
new file mode 100644
index 000000000000..8d387dbc59c8
--- /dev/null
+++ b/net-vpn/tinc/tinc-1.0.35.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="libressl +lzo uml vde +zlib"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}