summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/i2p/Manifest1
-rw-r--r--net-vpn/i2p/files/i2p.init19
-rw-r--r--net-vpn/i2p/files/i2p.service13
-rw-r--r--net-vpn/i2p/i2p-0.9.33.ebuild143
4 files changed, 176 insertions, 0 deletions
diff --git a/net-vpn/i2p/Manifest b/net-vpn/i2p/Manifest
index 600f3894eb77..fced4eedf7f2 100644
--- a/net-vpn/i2p/Manifest
+++ b/net-vpn/i2p/Manifest
@@ -1,2 +1,3 @@
DIST i2psource_0.9.30.tar.bz2 28035272 BLAKE2B 1e1b14b3126b8fd73489ddc99f7f83ea1b501d7c7ce31e11bbdb8e4a4fe33e06bf906277b7f10e912bdf54de8511c3c3d0eccf2607dcfaacb36ed89875425471 SHA512 59819125fd6aca9fd5ae25a424e78f25bd2e8f9ba995256f9bf7c1fb2a99cebf26a1dcaf1f202276f5656b4582c4b86fdcf9d23011f809b99764b0023fd243f8
DIST i2psource_0.9.31.tar.bz2 28745769 BLAKE2B e7766eceffb44c7c40ce176c3d98ed9a62472058c90adf1b07bbab11628d6ca4c8c62ca52526a204a6e8f47a182a59e07ccbdef65b6d2c5122d8e64e1df75406 SHA512 ffeb74d02c783febc122580b64561722de04c903e2d33fdeaf74bf3b7d725b8b7ce6556f53a12f0ae0d6c6deb413839e222bc2b8093952e5ecaf1bf96f0d1103
+DIST i2psource_0.9.33.tar.bz2 28985659 BLAKE2B 51b9697271c506de8d34b42ff208a12c9f0409c9aff456aa928dc2d411aceb0473878e9ed0d6ccf3684a7432c64700eec798535b4a4f4e01a2297e3d3ef7603a SHA512 ad772a422923636731350e590a14631209503c3d82db32410cb3002c790c60f9f7d950f94bb4d65ced1c2126e67a92ad65e9cd65ae3f045fc5279f57217066e2
diff --git a/net-vpn/i2p/files/i2p.init b/net-vpn/i2p/files/i2p.init
new file mode 100644
index 000000000000..bbc73b470053
--- /dev/null
+++ b/net-vpn/i2p/files/i2p.init
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+CONFIG_PATH="/var/lib/i2p/.i2p"
+INSTALL_PATH="/usr/share/i2p"
+WRAPPER_CONF="$INSTALL_PATH/wrapper.config"
+
+command=wrapper
+command_args="$WRAPPER_CONF wrapper.syslog.ident=i2p wrapper.logfile=$CONFIG_PATH/wrapper.log"
+command_background=true
+command_progress=true
+command_user=i2p
+pidfile="/var/run/i2p.pid"
+retry='SIGTERM/20 SIGKILL/20'
diff --git a/net-vpn/i2p/files/i2p.service b/net-vpn/i2p/files/i2p.service
new file mode 100644
index 000000000000..ccbadbd4d167
--- /dev/null
+++ b/net-vpn/i2p/files/i2p.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Invisible Internet Project
+After=network.target
+
+[Service]
+User=i2p
+Type=forking
+ExecReload=/usr/bin/i2prouter restart
+ExecStart=/usr/bin/i2prouter start
+ExecStop=/usr/bin/i2prouter stop
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-vpn/i2p/i2p-0.9.33.ebuild b/net-vpn/i2p/i2p-0.9.33.ebuild
new file mode 100644
index 000000000000..cf3d2654ed13
--- /dev/null
+++ b/net-vpn/i2p/i2p-0.9.33.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit java-pkg-2 java-ant-2 systemd user
+
+DESCRIPTION="A privacy-centric, anonymous network"
+HOMEPAGE="https://geti2p.net"
+SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
+SLOT="0"
+
+# Until the deps reach other arches
+KEYWORDS="~amd64 ~x86"
+IUSE="+ecdsa nls"
+
+# dev-java/ant-core is automatically added due to java-ant-2.eclass
+CP_DEPEND="dev-java/bcprov:1.50
+ dev-java/jrobin:0
+ dev-java/slf4j-api:0
+ dev-java/tomcat-jstl-impl:0
+ dev-java/tomcat-jstl-spec:0
+ dev-java/java-service-wrapper:0"
+
+DEPEND="${CP_DEPEND}
+ dev-java/eclipse-ecj:*
+ dev-libs/gmp:0
+ nls? ( >=sys-devel/gettext-0.19 )
+ >=virtual/jdk-1.7"
+
+RDEPEND="${CP_DEPEND}
+ ecdsa? (
+ || (
+ dev-java/icedtea:8[-sunec]
+ dev-java/icedtea-bin:8
+ dev-java/oracle-jre-bin
+ dev-java/oracle-jdk-bin
+ )
+ )
+ !ecdsa? ( >=virtual/jre-1.7 )"
+
+EANT_BUILD_TARGET="pkg"
+JAVA_ANT_ENCODING="UTF-8"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ enewgroup i2p
+ enewuser i2p -1 -1 "${EPREFIX}/var/lib/i2p" i2p
+}
+
+src_prepare() {
+ # as early as possible to allow generic patches to be applied
+ default
+
+ java-ant_rewrite-classpath
+
+ java-pkg-2_src_prepare
+
+ # We're on GNU/Linux, we don't need .exe files
+ echo "noExe=true" > override.properties || die
+ if ! use nls; then
+ echo "require.gettext=false" >> override.properties || die
+ fi
+
+ # avoid auto starting browser
+ sed -i 's|clientApp.4.startOnLoad=true|clientApp.4.startOnLoad=false|' \
+ 'installer/resources/clients.config' || die
+
+ # generate wrapper classpath, keeping the default to be replaced later
+ i2p_cp='' # global forced by java-pkg_gen-cp
+ java-pkg_gen-cp i2p_cp
+ local lib cp i=2
+ for lib in ${i2p_cp//,/ }
+ do
+ cp+="wrapper.java.classpath.$((i++))=$(java-pkg_getjars ${lib})\n"
+ done
+
+ # add generated cp and hardcode system VM
+ sed -e "s|\(wrapper\.java\.classpath\.1=.*\)|\1\n${cp}|" \
+ -e "s|\(wrapper\.java\.command\)=.*|\1=/etc/java-config-2/current-system-vm/bin/java|" \
+ -e "s|\(wrapper\.java\.library\.path\.1\)=.*|\1=/usr/lib/java-service-wrapper|" \
+ -i 'installer/resources/wrapper.config' || die
+
+ # replace paths as the installer would
+ sed -e "s|[\$%]INSTALL_PATH|${EPREFIX}/usr/share/i2p|" \
+ -e "s|%SYSTEM_java_io_tmpdir|${EPREFIX}/var/lib/i2p/.i2p|" \
+ -e "s|%USER_HOME|${EPREFIX}/var/lib/i2p|" \
+ -i 'installer/resources/'{eepget,i2prouter,runplain.sh,wrapper.config} || die
+}
+
+src_install() {
+ # cd into pkg-temp.
+ cd "${S}/pkg-temp" || die
+
+ # we remove system installed jar and install the others
+ rm lib/{jrobin.jar,wrapper.jar} || \
+ die 'unable to remove locally built jar already found in system'
+ java-pkg_dojar lib/*.jar
+
+ # Set up symlinks for binaries
+ dodir /usr/bin
+ # workaround portage absolute symlink limitation
+ dosym '../share/i2p/i2prouter' '/usr/bin/i2prouter'
+ dosym '../share/i2p/eepget' '/usr/bin/eepget'
+
+ # Install main files and basic documentation
+ exeinto '/usr/share/i2p'
+ insinto '/usr/share/i2p'
+ doins blocklist.txt hosts.txt *.config
+ doexe eepget i2prouter runplain.sh
+ dodoc history.txt INSTALL-headless.txt LICENSE.txt
+ doman man/*
+
+ # Install other directories
+ doins -r certificates docs eepsite geoip scripts
+ java-pkg_dowar webapps/*.war
+
+ # Install daemon files
+ newinitd "${FILESDIR}/i2p.init" i2p
+ systemd_dounit "${FILESDIR}/i2p.service"
+
+ # setup user
+ keepdir '/var/lib/i2p/.i2p'
+ fowners i2p:i2p '/var/lib/i2p/.i2p'
+}
+
+pkg_postinst() {
+ elog "Custom configuration belongs in ${EPREFIX}/var/lib/i2p/.i2p to avoid being overwritten."
+ elog 'I2P can be configured through the web interface at http://localhost:7657/console'
+
+ if use !ecdsa
+ then
+ ewarn 'Currently, the i2p team does not enforce to use ECDSA keys. But it is more and'
+ ewarn 'more pushed. To help the network, you are recommended to have the ecdsa USE.'
+ ewarn
+ ewarn "This is purely a run-time issue. You're free to build i2p with any JDK, as long as"
+ ewarn 'the JVM you run it with is one of the above listed and from the same or a newer generation'
+ ewarn 'as the one you built with.'
+ fi
+}