summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/hidclient/hidclient-20120728.ebuild')
-rw-r--r--net-wireless/hidclient/hidclient-20120728.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-wireless/hidclient/hidclient-20120728.ebuild b/net-wireless/hidclient/hidclient-20120728.ebuild
new file mode 100644
index 000000000000..97a7e7c1ae87
--- /dev/null
+++ b/net-wireless/hidclient/hidclient-20120728.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Use your machine as a bluetooh keyboard/mouse"
+HOMEPAGE="http://anselm.hoffmeister.be/computer/hidclient/"
+SRC_URI="http://anselm.hoffmeister.be/computer/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-wireless/bluez"
+RDEPEND="${DEPEND}
+ x11-apps/xinput"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i 's#gcc#$(CC)#' Makefile
+ sed -i 's#-O2#$(CFLAGS) $(LDFLAGS)#' Makefile
+}
+
+src_compile() {
+ emake hidclient
+}
+
+src_install() {
+ dosbin hidclient
+ dodoc "${FILESDIR}"/README
+}