summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/diagnostics/diagnostics-1.10.4.ebuild')
-rw-r--r--ros-meta/diagnostics/diagnostics-1.10.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/ros-meta/diagnostics/diagnostics-1.10.4.ebuild b/ros-meta/diagnostics/diagnostics-1.10.4.ebuild
new file mode 100644
index 000000000000..43185d0df3be
--- /dev/null
+++ b/ros-meta/diagnostics/diagnostics-1.10.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Packages related to gathering, viewing, and analyzing diagnostics data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_aggregator
+ dev-ros/diagnostic_analysis
+ dev-ros/diagnostic_common_diagnostics
+ dev-ros/diagnostic_updater
+ dev-ros/rosdiagnostic
+ dev-ros/self_test
+ dev-ros/test_diagnostic_aggregator
+"
+DEPEND="${RDEPEND}"