summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/qt_gui_core/qt_gui_core-0.4.2.ebuild')
-rw-r--r--ros-meta/qt_gui_core/qt_gui_core-0.4.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/ros-meta/qt_gui_core/qt_gui_core-0.4.2.ebuild b/ros-meta/qt_gui_core/qt_gui_core-0.4.2.ebuild
new file mode 100644
index 000000000000..a16c2e4cc475
--- /dev/null
+++ b/ros-meta/qt_gui_core/qt_gui_core-0.4.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Integration of ROS-specific plugins for a Qt-based GUI"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_dotgraph
+ dev-ros/qt_gui
+ dev-ros/qt_gui_app
+ dev-ros/qt_gui_cpp
+ dev-ros/qt_gui_py_common
+"
+DEPEND="${RDEPEND}"