summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch')
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch44
1 files changed, 22 insertions, 22 deletions
diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch
index 7a585b71894b..64b19a54c88a 100644
--- a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch
+++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch
@@ -93,30 +93,30 @@ index 1e0e7e2b32..834aff89cb 100644
--- a/src/external/CMakeLists.txt
+++ b/src/external/CMakeLists.txt
@@ -70,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib)
- set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
- SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
-
-+if(0)
- set(qtcompress_SRCS
- qtcompress/qzip.cpp
- qtcompress/qzipreader.h
+ set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
+
++if(0)
+ set(qtcompress_SRCS
+ qtcompress/qzip.cpp
+ qtcompress/qzipreader.h
@@ -82,6 +83,7 @@ target_link_libraries(qtcompress_stel ${ZLIB_LIBRARIES} Qt5::Core)
- #turn off automoc, not needed here
- set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0)
- SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external")
-+endif()
-
- set(qcustomplot_SRCS
- qcustomplot/qcustomplot.cpp
+ #turn off automoc, not needed here
+ set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external")
++endif()
+
+ set(qcustomplot_SRCS
+ qcustomplot/qcustomplot.cpp
@@ -176,7 +176,7 @@
- qxlsx/xlsxcelllocation.h
- )
- add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS})
--target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
-+target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress)
- set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
-
- ################################# INDI ################################
+ qxlsx/xlsxcelllocation.h
+ )
+ add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS})
+-target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
++target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress)
+ set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
+
+ ################################# INDI ################################
diff -r 11536448457a xlsxzipreader.cpp
--- a/src/external/qxlsx/xlsxzipreader.cpp Thu Oct 08 21:41:22 2020 +0100
+++ b/src/external/qxlsx/xlsxzipreader.cpp Thu Oct 08 21:42:03 2020 +0100