summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/Manifest3
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.5.2.ebuild55
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild (renamed from sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild)19
3 files changed, 10 insertions, 67 deletions
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index c9690cfad00a..27931ed46fba 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,3 +1,2 @@
-DIST pyephem-3.7.5.1.tar.gz 703441 SHA256 f24f8fc23c493fb842b44defc539762351a1d46b85f3d4f5043a002066afb50d SHA512 e26baec13c150350bbb84a28a1572c770642fe9a149a7036b2d6f0a4db8bdefaa7c762c1d24a7bb0607a7ed39684c081a1622ef395fd7590d22d80a3d3e68286 WHIRLPOOL 98cb525e6acc15e479e23bea83b753b1b2859f97338f666e1e2be5f7a0829868abbec8856c3417fd2361f30d488dc038e1e65883b1113e8c022b80e33fd1f75b
-DIST pyephem-3.7.5.2.tar.gz 705497 SHA256 3a0f33defbc1d48d196e62f71fc70e1e36095b7864eff3fb553e36dee3df20a1 SHA512 50ec88ee19072168672113c399e96f348feb5c6a5b4362bdcda7de5d079bb7e594c6858047cee53dd9cba9104e85dff9a44ff8981ab434f4ca162662d2a3bddd WHIRLPOOL f603ad3460d6d6348396d3dd946965b4e7a87594a879549d48ff5ead8431a4723e8ab61f216ad686cd539f09cbcc1b334359188f35f80879484cd19d509fbf82
DIST pyephem-3.7.5.3.tar.gz 735112 SHA256 cb0d7950d108aa5cbb1eb6e558086e98230de03ee1ede017a71701257b67eceb SHA512 a61b6a19c35c10ee9d4eba72cb0e6b9446076a3943be58dfd5e084bc9ab09dc70f2ee335ba5f0ef9d9d4d34a461bf4b9ddd57dae50d2e8a8f565d411e47f2908 WHIRLPOOL be28698df6214e769d03e74a67b353679a753723420e6a289b347b42c466c11253df9764f9e4e0fdda0424f4b62363b54fa58b520f45d480aae3a5883a84deae
+DIST pyephem-3.7.6.0.tar.gz 739561 SHA256 143146da32a07a4cf9725b5656ba095d24978c22a0363414203e72c39bae52bd SHA512 c3013ef943c0e1e2c30bba6f72912efb100b4c8c45904b7d6d7ba73d8b741564793a6e538117eb88abb824c93c874e2c955de734418ebd2370888718a149c9a8 WHIRLPOOL de8b8a4c86004adb2400a52f22514e5a25752d8e31fe7adbdffd08efa598d8d8c72726398f0ea49dfe3dcc6372c83d2586043ed987be3492c697c2818a2616e8
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.2.ebuild b/sci-astronomy/pyephem/pyephem-3.7.5.2.ebuild
deleted file mode 100644
index 45b6ebbd6344..000000000000
--- a/sci-astronomy/pyephem/pyephem-3.7.5.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Astronomical routines for the python programming language"
-HOMEPAGE="http://rhodesmill.org/pyephem/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-DEPEND="
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-src_prepare() {
- # don't install rst files
- sed -i -e "s:'doc/\*\.rst',::" setup.py || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- distutils-r1_src_compile
- if use doc; then
- PYTHONPATH=. emake -C src/ephem/doc html
- fi
-}
-
-python_test() {
- if [[ ${PYTHON_ABI} == "2.7" ]]; then
- PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
- ${EPYTHON} -m unittest discover -s src/ephem
- else
- PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
- unit2 discover -s src/ephem
- fi
-}
-
-src_install() {
- distutils-r1_src_install
- use doc && dohtml -r src/ephem/doc/_build/html/*
-
- delete_tests() {
- rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
- }
- python_foreach_impl delete_tests
-}
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
index 45b6ebbd6344..b9fe6e80d700 100644
--- a/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
+++ b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
@@ -17,12 +17,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
-DEPEND="
- doc? ( dev-python/sphinx )"
+DEPEND="doc? ( dev-python/sphinx )"
RDEPEND=""
src_prepare() {
- # don't install rst files
+ # don't install rst files by dfefault
sed -i -e "s:'doc/\*\.rst',::" setup.py || die
distutils-r1_src_prepare
}
@@ -30,23 +29,23 @@ src_prepare() {
src_compile() {
distutils-r1_src_compile
if use doc; then
- PYTHONPATH=. emake -C src/ephem/doc html
+ PYTHONPATH=. emake -C ephem/doc html
fi
}
python_test() {
if [[ ${PYTHON_ABI} == "2.7" ]]; then
PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
- ${EPYTHON} -m unittest discover -s src/ephem
+ ${EPYTHON} -m unittest discover -s ephem
else
PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
- unit2 discover -s src/ephem
+ unit2 discover -s ephem
fi
}
src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
distutils-r1_src_install
- use doc && dohtml -r src/ephem/doc/_build/html/*
delete_tests() {
rm -r "${D}$(python_get_sitedir)/ephem/tests" || die