summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bcftools/bcftools-1.10.2.ebuild')
-rw-r--r--sci-biology/bcftools/bcftools-1.10.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sci-biology/bcftools/bcftools-1.10.2.ebuild b/sci-biology/bcftools/bcftools-1.10.2.ebuild
deleted file mode 100644
index a484f69133e5..000000000000
--- a/sci-biology/bcftools/bcftools-1.10.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit python-single-r1
-
-DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
-HOMEPAGE="http://www.htslib.org"
-SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- dev-lang/perl
- $(python_gen_cond_dep '
- dev-python/matplotlib[${PYTHON_USEDEP}]
- ')
- =sci-libs/htslib-${PV}*:=
- sys-libs/zlib:=
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- python_fix_shebang misc/{guess-ploidy,plot-roh}.py
-
- # remove bundled htslib
- rm -r htslib-* || die
-}
-
-src_configure() {
- econf \
- --disable-bcftools-plugins \
- --disable-libgsl \
- --with-htslib=system
-}