summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bwa/bwa-0.7.12.ebuild')
-rw-r--r--sci-biology/bwa/bwa-0.7.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/bwa/bwa-0.7.12.ebuild b/sci-biology/bwa/bwa-0.7.12.ebuild
new file mode 100644
index 000000000000..76ed0cca912b
--- /dev/null
+++ b/sci-biology/bwa/bwa-0.7.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Burrows-Wheeler Alignment Tool, a fast short genomic sequence aligner"
+HOMEPAGE="http://bio-bwa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bio-bwa/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86 ~x64-macos"
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+ tc-export CC AR
+}
+
+src_install() {
+ dobin bwa
+
+ doman bwa.1
+
+ exeinto /usr/libexec/${PN}
+ doexe qualfa2fq.pl xa2multi.pl
+
+ dodoc NEWS.md README-alt.md README.md
+}