summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/embassy-hmmer')
-rw-r--r--sci-biology/embassy-hmmer/Manifest1
-rw-r--r--sci-biology/embassy-hmmer/embassy-hmmer-2.3.2.660.ebuild22
-rw-r--r--sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch101
3 files changed, 124 insertions, 0 deletions
diff --git a/sci-biology/embassy-hmmer/Manifest b/sci-biology/embassy-hmmer/Manifest
index cfef1c3b4a7b..6b9ca2ab9873 100644
--- a/sci-biology/embassy-hmmer/Manifest
+++ b/sci-biology/embassy-hmmer/Manifest
@@ -1 +1,2 @@
DIST embassy-hmmer-2.3.2.650.tar.gz 587775 SHA256 1464ff5e87c7c429f2fc78ac3554f8bd32cdaf49b8bed095fce6268b9afd4f6a SHA512 eb2c037fec70f4113b9ab59cc4eca9a608e8d0971a7bcc4612d60b1e28556444dd3ecdea4ff7b8f8b34711ad9f655334857e7510e89060459c81994a3abcc02a WHIRLPOOL 59027e96d3e629eb771fa966be95cd30138d6b97223056c95c1cc19d21ec0ffe555ff12f2cadc372ea303a0e06a9c1e673c4e32b2a50d8fd2ab2071d2c04cb83
+DIST embassy-hmmer-2.3.2.660.tar.gz 587775 SHA256 1464ff5e87c7c429f2fc78ac3554f8bd32cdaf49b8bed095fce6268b9afd4f6a SHA512 eb2c037fec70f4113b9ab59cc4eca9a608e8d0971a7bcc4612d60b1e28556444dd3ecdea4ff7b8f8b34711ad9f655334857e7510e89060459c81994a3abcc02a WHIRLPOOL 59027e96d3e629eb771fa966be95cd30138d6b97223056c95c1cc19d21ec0ffe555ff12f2cadc372ea303a0e06a9c1e673c4e32b2a50d8fd2ab2071d2c04cb83
diff --git a/sci-biology/embassy-hmmer/embassy-hmmer-2.3.2.660.ebuild b/sci-biology/embassy-hmmer/embassy-hmmer-2.3.2.660.ebuild
new file mode 100644
index 000000000000..7db8bf9ed7b9
--- /dev/null
+++ b/sci-biology/embassy-hmmer/embassy-hmmer-2.3.2.660.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EBO_DESCRIPTION="HMMER wrapper - sequence analysis with profile HMMs"
+
+EBO_EAUTORECONF=1
+
+inherit emboss-r2
+
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="sci-biology/hmmer:2"
+
+S="${WORKDIR}/HMMER-2.3.2.650"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.2.650_fix-build-system.patch
+ # sci-biology/hmmer:2 has renamed commandline program names
+ "${FILESDIR}"/${PN}-2.3.2.660-slotted-hmmer2.patch
+)
diff --git a/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch b/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch
new file mode 100644
index 000000000000..f202ddf3d0b5
--- /dev/null
+++ b/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch
@@ -0,0 +1,101 @@
+Amend command-line names for Gentoo SLOTed hmmer:2
+
+--- a/src/ehmmalign.c
++++ b/src/ehmmalign.c
+@@ -99,7 +99,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmalign"));
++ ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmalign2"));
+ if(mapali)
+ ajFmtPrintAppS(&cmd, " --mapali %s ", ajFileGetNameC(mapali));
+ if(withali)
+--- a/src/ehmmbuild.c
++++ b/src/ehmmbuild.c
+@@ -146,7 +146,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmbuild"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmbuild2"));
+ if(prior)
+ ajFmtPrintAppS(&cmd, " --prior %s ", ajFileGetNameC(prior));
+ if(null)
+--- a/src/ehmmcalibrate.c
++++ b/src/ehmmcalibrate.c
+@@ -98,7 +98,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmcalibrate"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmcalibrate2"));
+ if(cpu)
+ ajFmtPrintAppS(&cmd, " --cpu %d ", cpu);
+ if(fixed)
+--- a/src/ehmmconvert.c
++++ b/src/ehmmconvert.c
+@@ -72,7 +72,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmconvert"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmconvert2"));
+
+ /* ACD option only allows one selection */
+ option = ajStrGetCharFirst(format);
+--- a/src/ehmmemit.c
++++ b/src/ehmmemit.c
+@@ -79,7 +79,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmemit"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmemit2"));
+ ajFmtPrintAppS(&cmd, " --seed %d ", seed);
+ if(a)
+ ajStrAppendC(&cmd, " -a ");
+--- a/src/ehmmfetch.c
++++ b/src/ehmmfetch.c
+@@ -74,7 +74,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmfetch"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmfetch2"));
+ if(nhmm)
+ ajStrAppendC(&cmd, " -n ");
+ /* Note the output redirected to outfname */
+--- a/src/ehmmindex.c
++++ b/src/ehmmindex.c
+@@ -68,7 +68,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmindex"));
++ ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmindex2"));
+ ajStrAppendC(&cmd, ajFileGetNameC(database));
+
+
+--- a/src/ehmmpfam.c
++++ b/src/ehmmpfam.c
+@@ -122,7 +122,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmpfam"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmpfam2"));
+ if(nuc)
+ ajStrAppendC(&cmd, " -n ");
+ ajFmtPrintAppS(&cmd, " -A %d -E %f -T %f -Z %d", A, E, T, Z);
+--- a/src/ehmmsearch.c
++++ b/src/ehmmsearch.c
+@@ -102,7 +102,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmsearch"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmsearch2"));
+ ajFmtPrintAppS(&cmd, " -A %d -E %f -T %f -Z %d", A, E, T, Z);
+ if(compat)
+ ajStrAppendC(&cmd, " --compat ");