summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/last/last-230.ebuild')
-rw-r--r--sci-biology/last/last-230.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-biology/last/last-230.ebuild b/sci-biology/last/last-230.ebuild
new file mode 100644
index 000000000000..51dc9ee0faf0
--- /dev/null
+++ b/sci-biology/last/last-230.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
+src_compile() {
+ emake \
+ -e -C src \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ STRICT="" || die
+}
+
+src_install() {
+ dobin src/last{al,db,ex}
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+ dodoc doc/*.txt ChangeLog.txt README.txt
+}