summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/raxml/raxml-7.2.6.ebuild')
-rw-r--r--sci-biology/raxml/raxml-7.2.6.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/sci-biology/raxml/raxml-7.2.6.ebuild b/sci-biology/raxml/raxml-7.2.6.ebuild
index 50fffc34accb..adb044426381 100644
--- a/sci-biology/raxml/raxml-7.2.6.ebuild
+++ b/sci-biology/raxml/raxml-7.2.6.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
+S="${WORKDIR}/RAxML-${PV}"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cpu_flags_x86_sse3 +threads"
-
REQUIRED_USE="cpu_flags_x86_sse3"
# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
-DEPEND="" # mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/RAxML-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
- use cpu_flags_x86_sse3 && append-cflags -D__SIM_SSE3
+src_configure() {
+ use cpu_flags_x86_sse3 && append-cppflags -D__SIM_SSE3
use threads && \
- append-cflags -D_USE_PTHREADS && \
- append-ldflags -pthread
+ append-cppflags -D_USE_PTHREADS && \
+ append-libs -pthread
tc-export CC
}