summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
new file mode 100644
index 000000000000..47b4f3e455c0
--- /dev/null
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple hex calculator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/"
+SRC_URI="ftp://ftp.x.org/R5contrib/${PN}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ app-text/rman"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${PN}-{keypad,order}.diff )
+
+src_compile() {
+ xmkmf || die
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CCLINK="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.{man,1}
+}