summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/transcalc')
-rw-r--r--sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch70
-rw-r--r--sci-calculators/transcalc/transcalc-0.14-r2.ebuild14
2 files changed, 78 insertions, 6 deletions
diff --git a/sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch b/sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch
new file mode 100644
index 000000000000..1e9288c74b93
--- /dev/null
+++ b/sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch
@@ -0,0 +1,70 @@
+--- a/src/transcalc.c
++++ b/src/transcalc.c
+@@ -37,6 +37,15 @@
+ extern gint trc_file_load (FILE *, short);
+
+ char version[] = "transcalc " VERSION;
++GtkWidget *main_body_window;
++GtkWidget *transtype_combo;
++
++short current_transtype;
++trans_win *twin;
++short statusint;
++trans_gui *tgui;
++gboolean statusexists;
++int main_window_width, main_window_height;
+
+
+ /*
+--- a/src/transcalc.h
++++ b/src/transcalc.h
+@@ -53,8 +53,8 @@
+ #endif /* HAVE_STRCPY */
+
+
+-GtkWidget *main_body_window;
+-GtkWidget *transtype_combo;
++extern GtkWidget *main_body_window;
++extern GtkWidget *transtype_combo;
+ /*GtkWidget *status;*/
+
+ #define MICROSTRIP 0
+@@ -163,12 +163,12 @@
+ gfloat electrical_params_value[NUMELECPARS];
+ } trans_value;
+
+-short current_transtype;
+-trans_win *twin;
+-short statusint;
+-trans_gui *tgui;
+-gboolean statusexists;
+-int main_window_width, main_window_height;
++extern short current_transtype;
++extern trans_win *twin;
++extern short statusint;
++extern trans_gui *tgui;
++extern gboolean statusexists;
++extern int main_window_width, main_window_height;
+
+ void error_mes(gchar * text);
+
+--- a/src/unitscombo.c
++++ b/src/unitscombo.c
+@@ -33,6 +33,7 @@
+ #include "transcalc.h"
+ #include "body.h"
+
++short length_unit, freq_unit, res_unit, ang_unit;
+
+ gchar *length_unit_name[] = { "mil",
+ "cm",
+--- a/src/units.h
++++ b/src/units.h
+@@ -77,6 +77,6 @@
+ #define ohm_to_kohm(a) (a/1000.0)
+ */
+
+-short length_unit, freq_unit, res_unit, ang_unit;
++extern short length_unit, freq_unit, res_unit, ang_unit;
+
+ #endif
diff --git a/sci-calculators/transcalc/transcalc-0.14-r2.ebuild b/sci-calculators/transcalc/transcalc-0.14-r2.ebuild
index 02376bc9ed7a..b6c144a8b7ff 100644
--- a/sci-calculators/transcalc/transcalc-0.14-r2.ebuild
+++ b/sci-calculators/transcalc/transcalc-0.14-r2.ebuild
@@ -1,28 +1,30 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Microwave and RF transmission line calculator"
HOMEPAGE="http://transcalc.sourceforge.net"
SRC_URI="http://transcalc.sourceforge.net/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}"
# patch from debian
-PATCHES=( "${FILESDIR}"/${P}-fd-perm.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fd-perm.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
+ default
+
# respect flags
sed -i -e 's|^CFLAGS=|#CFLAGS=|g' configure || die
- default
# syntax errors
sed -i \
-e 's/ythesize/ynthesize/g' \