summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/orpie/Manifest1
-rw-r--r--sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch4
-rw-r--r--sci-calculators/orpie/files/orpie-1.5.2-nogsl.patch51
-rw-r--r--sci-calculators/orpie/orpie-1.5.2.ebuild49
4 files changed, 103 insertions, 2 deletions
diff --git a/sci-calculators/orpie/Manifest b/sci-calculators/orpie/Manifest
index 06f3378036db..39452413b4a7 100644
--- a/sci-calculators/orpie/Manifest
+++ b/sci-calculators/orpie/Manifest
@@ -1 +1,2 @@
DIST orpie-1.5.1.tar.gz 370851 SHA256 f68ee37a5351c1dd32a68edae253a22a913fc2124bace1f6cf19cc2d422100cd SHA512 026afcaf37016f07397ba19629a92c5bdffbbec6d25b5f96e9367274afbf7468a7d6626b4ae81d1c9b426dde3a2c66a97e9b48c54dfb3a8079f0d59906f0efb7 WHIRLPOOL 30ba5f026ffc1f704a08d6090eabe6d47f8dfe96ec49ba6a6a772dd85337a54fe7de2b382015e832fc0058e7449a1829fedc6fc87683a074d0cac82dad48150e
+DIST orpie-1.5.2.tar.gz 379583 SHA256 de557fc7f608c6cb1f44a965d3ae07fc6baf2b02a0d7994b89d6a0e0d87d3d6d SHA512 5deed6d8e8e68ce5286f4d5183315b585adef38f205805ff6ccbbbf3983c97a468e370d0d44ebe2dff596de0ad9dba20401dbc0e4e9bc176bc93b118fd1cc11a WHIRLPOOL 390c681dbc72d9730cbf22551ffa951f77e7a3589bf10c244fd1c0a3bc2ad81107ff8f5ede196b6486f50ed8f106554a8db03b04979cd5a88da31de4c1aeb836
diff --git a/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch b/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch
index 45894f2039dc..8719bfd1c5d3 100644
--- a/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch
+++ b/sci-calculators/orpie/files/orpie-1.5.1-nogsl.patch
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2010-06-03 21:02:14.000000000 +0100
-+++ Makefile.in 2010-06-03 21:02:49.000000000 +0100
+--- orpie-1.5.1/Makefile.in.orig 2010-06-03 21:02:14.000000000 +0100
++++ orpie-1.5.1/Makefile.in 2010-06-03 21:02:49.000000000 +0100
@@ -38,7 +38,7 @@
CURSES_LIB = @CURSES_LIB@
GSL_LIB = @GSL_LIB@
diff --git a/sci-calculators/orpie/files/orpie-1.5.2-nogsl.patch b/sci-calculators/orpie/files/orpie-1.5.2-nogsl.patch
new file mode 100644
index 000000000000..75a56a79c0e6
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-1.5.2-nogsl.patch
@@ -0,0 +1,51 @@
+--- orpie-1.5.2/Makefile.in
++++ orpie-1.5.2/Makefile.in
+@@ -44,7 +44,7 @@
+ CURSES_LIB = @CURSES_LIB@
+ GSL_LIB = @GSL_LIB@
+
+-INCLUDES = -I ./curses -I ./gsl -I ./units
++INCLUDES = -I ./curses -I /usr/lib/ocaml/gsl -I ./units
+ BFLAGS = -pp camlp4o -g $(INCLUDES) -thread
+ OFLAGS = -pp camlp4o $(INCLUDES) -thread
+ BLFLAGS = -custom -cclib '$(LDFLAGS) $(CURSES_LIB) $(GSL_LIB) -lm'
+@@ -78,17 +78,8 @@
+ CURSES_BOBJS = $(CURSES_CMO) $(CURSES_COBJS)
+ CURSES_OOBJS = $(CURSES_CMX) $(CURSES_COBJS)
+
+-GSL_CMO = gsl/gsl_error.cmo gsl/gsl_blas.cmo gsl/gsl_complex.cmo gsl/gsl_matrix.cmo gsl/gsl_matrix_complex.cmo \
+- gsl/gsl_vector.cmo gsl/gsl_vector_complex.cmo gsl/gsl_vector_flat.cmo gsl/gsl_matrix_flat.cmo \
+- gsl/gsl_vector_complex_flat.cmo gsl/gsl_matrix_complex_flat.cmo gsl/gsl_vectmat.cmo \
+- gsl/gsl_permut.cmo gsl/gsl_linalg.cmo gsl/gsl_fun.cmo
+-GSL_CMX = $(GSL_CMO:.cmo=.cmx)
+-GSL_COBJS = gsl/mlgsl_error.o gsl/mlgsl_blas.o gsl/mlgsl_blas_complex.o gsl/mlgsl_complex.o gsl/mlgsl_blas_float.o \
+- gsl/mlgsl_blas_complex_float.o gsl/mlgsl_matrix_complex.o gsl/mlgsl_matrix_double.o gsl/mlgsl_matrix_float.o \
+- gsl/mlgsl_matrix_complex_float.o gsl/mlgsl_vector_double.o gsl/mlgsl_vector_float.o \
+- gsl/mlgsl_permut.o gsl/mlgsl_linalg.o gsl/mlgsl_linalg_complex.o gsl/mlgsl_fun.o gsl/mlgsl_math.o gsl/mlgsl_sf.o
+-GSL_BOBJS = $(GSL_COBJS) $(GSL_CMO)
+-GSL_OOBJS = $(GSL_COBJS) $(GSL_CMX)
++GSL_BOBJS = /usr/lib/ocaml/gsl/gsl.cma
++GSL_OOBJS = /usr/lib/ocaml/gsl/gsl.cmxa
+
+ UNITS_CMO = units/units.cmo
+ UNITS_CMX = $(UNITS_CMO:.cmo=.cmx)
+@@ -324,7 +305,7 @@
+ config.status: configure
+ ./config.status --recheck
+
+-configure: configure.in
++configure: configure.ac
+ autoconf
+
+ # clean
+--- orpie-1.5.2/curses_keys.ml
++++ orpie-1.5.2/curses_keys.ml
+@@ -19,7 +19,7 @@
+ *)
+
+ open Curses;;
+-
++open Curses_assist;;
+
+ begin
+ let std = initscr () in
diff --git a/sci-calculators/orpie/orpie-1.5.2.ebuild b/sci-calculators/orpie/orpie-1.5.2.ebuild
new file mode 100644
index 000000000000..ed7cc745bb1c
--- /dev/null
+++ b/sci-calculators/orpie/orpie-1.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A fullscreen RPN calculator for the console"
+HOMEPAGE="http://pessimization.com/software/orpie/"
+SRC_URI="http://pessimization.com/software/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-ml/ocamlgsl
+ sys-libs/ncurses:0=
+ || ( <dev-lang/ocaml-4.02 dev-ml/camlp4 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.1-ocaml311.patch"
+ "${FILESDIR}/${P}-nogsl.patch"
+ "${FILESDIR}/${PN}-1.5.1-orpierc.patch"
+ "${FILESDIR}/${PN}-1.5.1-tinfo.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile.in || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ # TODO: fix missing edges in dependency graph
+ emake -j1
+}
+
+src_install() {
+ default
+ if use doc; then
+ dodoc doc/manual.pdf
+ docinto html/
+ dodoc doc/manual.html
+ fi
+}