summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2022.9999.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
index 655c647a73dd..101a76d94cf9 100644
--- a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
@@ -85,12 +85,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}