summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/propka')
-rw-r--r--sci-chemistry/propka/Manifest2
-rw-r--r--sci-chemistry/propka/metadata.xml3
-rw-r--r--sci-chemistry/propka/propka-3.4.0.ebuild (renamed from sci-chemistry/propka/propka-3.2.0.ebuild)30
3 files changed, 12 insertions, 23 deletions
diff --git a/sci-chemistry/propka/Manifest b/sci-chemistry/propka/Manifest
index 4141de909047..a3ae32cc089e 100644
--- a/sci-chemistry/propka/Manifest
+++ b/sci-chemistry/propka/Manifest
@@ -1 +1 @@
-DIST propka-3.2.0.tar.gz 73746 BLAKE2B f79e493d5a195b81dc5d11cc21b9ab16c8d1fa48f15f7e23e2b2936dfb8634fdb00c7838b8dbdb4a68726dab0f16e54522ad71d71b3273ac93c03a737ae06f04 SHA512 98f2240b28b33bab94cdbe9392062bb7f6b87e75b94c2af91e178f874a74d210601161ebc835c4d751b89d37b32348fdfb096e28cbf8e9237b3f472d3fb6b4fc
+DIST propka-3.4.0.gh.tar.gz 363641 BLAKE2B 87f495ba69028593cf3ebf98ed33da0944f7a3833f2d08cae4f0a0b5cbe2f3a67e9812685b896a7d89c88ba25653861f135dbac53dc6df7af426a290bacb3d22 SHA512 2ce431c66374d0692acb7504661caa870ab6460ace3a6478f88c1d46a7bfcd82c748bf153a1ce2ea6d1611bc4bbf2351c4f5149f4578e5f8a9f9ec8385298fe9
diff --git a/sci-chemistry/propka/metadata.xml b/sci-chemistry/propka/metadata.xml
index 6bfad85b4001..5153791d2361 100644
--- a/sci-chemistry/propka/metadata.xml
+++ b/sci-chemistry/propka/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci-chemistry@gentoo.org</email>
@@ -9,4 +9,5 @@
<remote-id type="pypi">propka</remote-id>
<remote-id type="github">jensengroup/propka</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/sci-chemistry/propka/propka-3.2.0.ebuild b/sci-chemistry/propka/propka-3.4.0.ebuild
index b5dadd1825d2..81b20fbee2e0 100644
--- a/sci-chemistry/propka/propka-3.2.0.ebuild
+++ b/sci-chemistry/propka/propka-3.4.0.ebuild
@@ -1,40 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="pKa-value prediction of ionizable groups in protein and protein-ligand complexes"
HOMEPAGE="https://github.com/jensengroup/propka"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/jensengroup/propka/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- ${RDEPEND}
- dev-python/pandas[${PYTHON_USEDEP}]
-)"
+
+distutils_enable_tests pytest
python_prepare_all() {
- sed -e "/exclude/s:scripts:\', \'Tests:g" \
+ # Do not install the tests
+ sed -e "/exclude/s:scripts:\', \'tests:g" \
-i setup.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- cd Tests || die
- ${PYTHON} runtest.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-}