summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.5.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.5.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.5.ebuild
new file mode 100644
index 000000000000..7cbd8d88dc7a
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )