summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol/Manifest1
-rw-r--r--sci-chemistry/pymol/pymol-1.7.7.2.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 6779a0733a60..b660c664cc1d 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,3 +1,4 @@
DIST pymol-1.7.0.0.png.xz 5392 SHA256 4c554a5c4f47946b6f7bae00209d5116305162534292735d30ae0794c56a8a0b SHA512 24bb1584b28688f5d5824e938f8500ca9887838adf490b4284c52f8c0da4c5ec4a56051ee80f48e4f34541ab53f9a4e00c849c382f1fd37c232fbea12d700105 WHIRLPOOL 395f978eb9ea3a8f8f39bf0694f71986ac9f8ebb307b90283c53fed85c4412d84e54af472f8646fcbd99c650039cb395a8f02b281168802c73ddb9bad175512b
DIST pymol-1.7.4.0.tar.xz 6528964 SHA256 5a732aeb8a02797a185f54c3bd8bb477a1a11976eb9f982f6cf79ce887ce3a4a SHA512 fa53e90413cb1e02797a30b21b4254901504edc029104567fd2d4c5ef630eb8c2eb9f5065b2b9e65f657aaa30ca8ac85c3314c6c7fbb89148d89a9a0964de3cf WHIRLPOOL 1467a9746abe60e371162e6065253fbb23453f80a4757a18936f5b6509f63657b7073ee5e118c7e4faf333371cd38c78917e1f4b0a3a684b4807972546180d69
DIST pymol-1.7.6.0.tar.xz 6510380 SHA256 31d4924378b38b65fae5b294e0755ee15916f9e845ef2efe5e2421f463bf3b91 SHA512 ff8c37de07e0ed8dc1176224eea439109f2bd5e42b5c08316f5737a2fdcf5a1f267b625c166fa740296c20ef089873ae1ad6cb89b11111e9d3aeda0b6035d55d WHIRLPOOL 3582cc846695ca580a4bcd31db8079f32d3cb0d84b8fa1afeb0b210d7004642bf58eab42cafd552f360a5e20b546e554cf5420b7dd2e8cefa5b956a9453215e2
+DIST pymol-1.7.7.2.tar.xz 6527780 SHA256 fc15fc8fbf23b422c5d19babd20e19b7d7ab8ee9532012c7b3a27b87af44fdae SHA512 faf3715cd6b9e7115f6501fc4480a6f71fe53d3b02b2eeefdd07a57d7c15b3621c05fd3894bb92ac4042edaa224d99c2be7488a762254d069c581974a0146179 WHIRLPOOL b52683ce1dc265fe302c974ccc1bfa9e55365e8502f944cf6527c0071f207fcb54e8b3ad38fd684b66c66f85fa6a03f2f1178b90fd406b9f7561d956c704fb9a
diff --git a/sci-chemistry/pymol/pymol-1.7.7.2.ebuild b/sci-chemistry/pymol/pymol-1.7.7.2.ebuild
new file mode 100644
index 000000000000..a16c696f2cf6
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.7.7.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 fdo-mime flag-o-matic versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ https://dev.gentoo.org/~jlec/distfiles/${PN}-1.7.0.0.png.xz
+ https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz
+"
+# mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="apbs web"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freeglut
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/python-pmw[${PYTHON_USEDEP}]
+ apbs? (
+ sci-chemistry/apbs[${PYTHON_USEDEP}]
+ sci-chemistry/pdb2pqr[${PYTHON_USEDEP}]
+ !sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ )
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P}/${PN}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+
+ append-cxxflags -std=c++0x
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
+
+ sed \
+ -e '1d' \
+ -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
+ -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ sed \
+ -e '1i#!/usr/bin/env python' \
+ "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
+
+ python_foreach_impl python_doscript "${T}"/${PN}
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/usr/share/pymol"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.7.0.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}