summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/files/ffmpeg4.patch30
-rw-r--r--sci-electronics/gazebo/gazebo-9.0.0.ebuild2
2 files changed, 31 insertions, 1 deletions
diff --git a/sci-electronics/gazebo/files/ffmpeg4.patch b/sci-electronics/gazebo/files/ffmpeg4.patch
new file mode 100644
index 000000000000..7bd8777dea3f
--- /dev/null
+++ b/sci-electronics/gazebo/files/ffmpeg4.patch
@@ -0,0 +1,30 @@
+Index: gazebo-9.0.0/gazebo/common/AudioDecoder.cc
+===================================================================
+--- gazebo-9.0.0.orig/gazebo/common/AudioDecoder.cc
++++ gazebo-9.0.0/gazebo/common/AudioDecoder.cc
+@@ -255,8 +255,8 @@ bool AudioDecoder::SetFile(const std::st
+ return false;
+ }
+
+- if (this->codec->capabilities & CODEC_CAP_TRUNCATED)
+- this->codecCtx->flags |= CODEC_FLAG_TRUNCATED;
++ if (this->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ this->codecCtx->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ // Open codec
+ if (avcodec_open2(this->codecCtx, this->codec, nullptr) < 0)
+Index: gazebo-9.0.0/gazebo/common/Video.cc
+===================================================================
+--- gazebo-9.0.0.orig/gazebo/common/Video.cc
++++ gazebo-9.0.0/gazebo/common/Video.cc
+@@ -143,8 +143,8 @@ bool Video::Load(const std::string &_fil
+
+ // Inform the codec that we can handle truncated bitstreams -- i.e.,
+ // bitstreams where frame boundaries can fall in the middle of packets
+- if (codec->capabilities & CODEC_CAP_TRUNCATED)
+- this->codecCtx->flags |= CODEC_FLAG_TRUNCATED;
++ if (codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ this->codecCtx->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ // Open codec
+ if (avcodec_open2(this->codecCtx, codec, nullptr) < 0)
diff --git a/sci-electronics/gazebo/gazebo-9.0.0.ebuild b/sci-electronics/gazebo/gazebo-9.0.0.ebuild
index 76ad65771aa8..77f42540c99b 100644
--- a/sci-electronics/gazebo/gazebo-9.0.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-9.0.0.ebuild
@@ -57,7 +57,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=( "${FILESDIR}/qwt.patch" )
+PATCHES=( "${FILESDIR}/qwt.patch" "${FILESDIR}/ffmpeg4.patch" )
src_configure() {
# doesnt build without it