summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild b/sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild
new file mode 100644
index 000000000000..1f9c78cf8510
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+inherit cmake-utils wxwidgets
+
+MY_PN="ocpndebugger_pi"
+
+DESCRIPTION="NMEA-data and plugin-API Debugger Plugin for OpenCPN"
+HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
+SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-geosciences/opencpn-4.0.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"