summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
index 7318cf9e6c91..a2b93f3991c2 100644
--- a/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
+++ b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="route_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/SaltyPaws/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/SaltyPaws/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/SaltyPaws/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/SaltyPaws/route_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}