summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-3.34.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index bcb6da30bace..9c453618b0c5 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1 +1,2 @@
DIST gnome-maps-3.30.3.1.tar.xz 2175840 BLAKE2B 0c2f44ec3262715d98e1a0412ca305e15916cdb92df5fc5b04df34b65a7b9c55d4f5dd9c54f9f9dc34f8e6dd889f60d7993b59ca0cd92e4e60b22b506877b24c SHA512 02d3b1b305c1011a60a34566847962ec3c32ee3563ce2c327b810fae24c2df08354d8420f1986645d861cfef7a35f336d67d4576a3e2f61eabdd972b8d070a8e
+DIST gnome-maps-3.34.2.tar.xz 3973480 BLAKE2B b2a4ff993ccecb27c79599485278fdffcd64b22d5cdf011a73106e883c75b72e4a5160a1d5c05a1e9324ecd458371a5e512855dc1d59f14e06e711b00e4128f8 SHA512 8f7f88343bee22aff9d9e821d2059c4428788d9a43ada7415387721664a58fa1bc7ff36865fc7d12702e77fa794d87d3e3fb80aab694fb6c014fd4dbc1db0f0c
diff --git a/sci-geosciences/gnome-maps/gnome-maps-3.34.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-3.34.2.ebuild
new file mode 100644
index 000000000000..ae5809e033e4
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-3.34.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/gjs-1.50.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}