summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
index 990f5c9422a8..26bab47005f2 100644
--- a/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake flag-o-matic
DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
@@ -19,7 +19,7 @@ COMMON_DEPEND="
app-arch/bzip2
dev-db/postgresql:=
dev-libs/expat
- sci-libs/proj
+ sci-libs/proj:=
sys-libs/zlib
lua? ( dev-lang/lua:= )
"
@@ -34,9 +34,10 @@ RDEPEND="${COMMON_DEPEND}
RESTRICT="test"
src_configure() {
+ append-cppflags -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1
local mycmakeargs=(
-DWITH_LUA=$(usex lua)
-DBUILD_TESTS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}