summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/adolc')
-rw-r--r--sci-libs/adolc/Manifest1
-rw-r--r--sci-libs/adolc/adolc-2.6.2.ebuild53
-rw-r--r--sci-libs/adolc/files/adolc-2.5.0-pkgconfig-no-ldflags.patch4
-rw-r--r--sci-libs/adolc/files/adolc-2.6.2-dash.patch146
4 files changed, 202 insertions, 2 deletions
diff --git a/sci-libs/adolc/Manifest b/sci-libs/adolc/Manifest
index 39489cbe99b8..1b3eb2eb743f 100644
--- a/sci-libs/adolc/Manifest
+++ b/sci-libs/adolc/Manifest
@@ -1,3 +1,4 @@
DIST ADOL-C-2.4.1.tgz 2210414 SHA256 05bf946cc1764e2b3fa7e708ccc4303f289699d9f36b9d525f6a9a6129b4d578 SHA512 5e5135ca587d159510bf77338fdff3d324f4d32c4ec6f8cf64ddc92253b427b8ee26a30bc1d83fe18121bbfdc7454c3536f58849c0c335e1b240e39d46acdccc WHIRLPOOL cd66a895dc3cb1f6f4f705a9fbce5a93dcb6856b6288704c3d3420be7f90e57296acd3fb2ea897ba5362e706429ec56b070bf0baa7094edcbf46c92d535bc492
DIST ADOL-C-2.5.0.tgz 2313753 SHA256 908753153e0eca31752222150977eabd8ab97c4ab8fcd19f92667aba69a048a6 SHA512 e680565ed911bc15165c27281428c1daf35e95292dc3abc64aab6633068ec0d7e7ae626e692e0574b2c696a0c4aec2c79b2b02c3760acd2bd1b579a4c42d9585 WHIRLPOOL c0301c9a8f1357aa06be8e6a53bee9825a5d56cd31a2734862bcfd1f7c944935a4cd2c8c2ed49028493cb7c998008c9853b2d4bd7f6e0519ed353bbd3b7d0a8c
DIST ADOL-C-2.5.2.tgz 2320010 SHA256 2fa514d9799989d6379738c2bcf75070d9834e4d227eb32a5b278840893b2af9 SHA512 3d2ef6e42504de9e9c1b5777afda8ece83fa61ab7c22fd471dce6bcb74af0a789d37cd2a6c9c9ead13f6c78e07ba985e7d14e79bcdf35fa56f8e73a2411905b5 WHIRLPOOL 55043cabe44b9913a7fba73ddaf0d64caa234d7002582d78dd9cfc05510ce3fbcb6dd3d1c40a2d6425f5ee1b7cc986d525d065671191096fbb303e122089c954
+DIST ADOL-C-2.6.2.tgz 2413458 SHA256 f6326e7ba994d02074816132d4461915221069267c31862b31fab7020965c658 SHA512 7825b57a06ea146b5095f3345592566887622e4a8b93bf8ef946083486652b5ecd6a44b7b5f1c7a5b5c45cfdb14d78ab2dd5f4d228114226046e99a46257f5be WHIRLPOOL 24a2013e99b2fcbab348f2051a5592b5040ccd0349801838397a60833ba3baf36a21f125234bb8a721dcda7e504f3f4e79e792bdf8ad4965dae6158ccbef0054
diff --git a/sci-libs/adolc/adolc-2.6.2.ebuild b/sci-libs/adolc/adolc-2.6.2.ebuild
new file mode 100644
index 000000000000..5ef274ec40aa
--- /dev/null
+++ b/sci-libs/adolc/adolc-2.6.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs eutils
+
+MYPN=ADOL-C
+
+DESCRIPTION="Automatic differentiation system for C/C++"
+HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="|| ( EPL-1.0 GPL-2 )"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi sparse static-libs"
+
+RDEPEND="
+ mpi? ( sys-cluster/ampi:0= )
+ sparse? ( sci-libs/colpack:0= )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.0-no-colpack.patch
+ "${FILESDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
+ "${FILESDIR}"/${PN}-2.6.2-dash.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable mpi ampi) \
+ $(use_enable sparse) \
+ $(use_with sparse colpack "${EPREFIX}"/usr)
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sci-libs/adolc/files/adolc-2.5.0-pkgconfig-no-ldflags.patch b/sci-libs/adolc/files/adolc-2.5.0-pkgconfig-no-ldflags.patch
index 4a6296e2db75..258f835ca9e8 100644
--- a/sci-libs/adolc/files/adolc-2.5.0-pkgconfig-no-ldflags.patch
+++ b/sci-libs/adolc/files/adolc-2.5.0-pkgconfig-no-ldflags.patch
@@ -1,5 +1,5 @@
---- adolclib.pc.in.orig 2014-05-21 09:09:10.060824555 -0700
-+++ adolclib.pc.in 2014-05-21 09:09:10.060824555 -0700
+--- a/adolclib.pc.in 2014-05-21 09:09:10.060824555 -0700
++++ b/adolclib.pc.in 2014-05-21 09:09:10.060824555 -0700
@@ -7,5 +7,5 @@
Version: @PACKAGE_VERSION@
Description: Algorithmic Differentiation Library for C/C++
diff --git a/sci-libs/adolc/files/adolc-2.6.2-dash.patch b/sci-libs/adolc/files/adolc-2.6.2-dash.patch
new file mode 100644
index 000000000000..b8d4fe5ad64d
--- /dev/null
+++ b/sci-libs/adolc/files/adolc-2.6.2-dash.patch
@@ -0,0 +1,146 @@
+--- a/configure.ac 2016-08-31 12:49:35.000000000 +0000
++++ b/configure.ac 2017-03-04 00:58:02.354372332 +0000
+@@ -29,12 +29,12 @@
+
+ adolclib=adolc
+
+-if test "x$CFLAGS" == x ; then
++if test "x$CFLAGS" = x ; then
+ ac_shell_cflags="not_set"
+ else
+ ac_shell_cflags="$CFLAGS"
+ fi
+-if test "x$CXXFLAGS" == x ; then
++if test "x$CXXFLAGS" = x ; then
+ ac_shell_cxxflags="not_set"
+ else
+ ac_shell_cxxflags="$CXXFLAGS"
+@@ -231,12 +231,12 @@
+ AC_MSG_RESULT(no)
+ ])
+
+-if test x$adolc_harddebug == xyes ; then
++if test x$adolc_harddebug = xyes ; then
+ adolc_debug=yes
+ AC_DEFINE(ADOLC_HARDDEBUG,1,[ADOL-C hard debug mode])
+ fi
+
+-if test x$adolc_debug == xyes ; then
++if test x$adolc_debug = xyes ; then
+ AC_DEFINE(ADOLC_DEBUG,1,[ADOL-C debug mode])
+ fi
+
+@@ -254,7 +254,7 @@
+ AC_MSG_RESULT(yes)
+ ])
+
+-if test x$adolc_stdczero == xyes; then
++if test x$adolc_stdczero = xyes; then
+ AC_DEFINE(ADOLC_ADOUBLE_STDCZERO,1,[ADOL-C adouble zeroing mode])
+ fi
+
+@@ -271,7 +271,7 @@
+ AC_MSG_RESULT(no)
+ ])
+
+-if test x$adolc_late_init == xyes; then
++if test x$adolc_late_init = xyes; then
+ AC_DEFINE(ADOLC_ADOUBLE_LATEINIT,1,[ADOL-C adouble late initialization mode])
+ fi
+
+@@ -288,7 +288,7 @@
+ AC_MSG_RESULT(no)
+ ])
+
+-if test x$adolc_tserrno == xyes ; then
++if test x$adolc_tserrno = xyes ; then
+ AC_DEFINE(ADOLC_THREADSAVE_ERRNO,1,[ADOL-C thread save errno mode])
+ fi
+
+@@ -376,8 +376,8 @@
+ [AS_HELP_STRING([--with-cflags=FLAGS],
+ [use CFLAGS=FLAGS (default: -O2)])],
+ [ac_adolc_cflags="$withval"
+- if test x${adolc_debug} == xyes ||
+- test x${adolc_harddebug} == xyes ; then
++ if test "x${adolc_debug}" = xyes ||
++ test "x${adolc_harddebug}" = xyes ; then
+ ac_adolc_cflags="$ac_adolc_cflags -g -O0"
+ fi
+ ac_adolc_cflags="$ac_adolc_cflags $ac_adolc_openmpflag"
+@@ -385,8 +385,8 @@
+ AC_MSG_RESULT($ac_adolc_cflags)],
+ [if test "$ac_shell_cflags" = "not_set"; then
+ ac_adolc_cflags="-O2"
+- if test x${adolc_debug} == xyes ||
+- test x${adolc_harddebug} == xyes ; then
++ if test "x${adolc_debug}" = xyes ||
++ test "x${adolc_harddebug}" = xyes ; then
+ ac_adolc_cflags="-g -O0 -Wall -ansi"
+ fi
+ else
+@@ -402,8 +402,8 @@
+ [AS_HELP_STRING([--with-cxxflags=FLAGS],
+ [use CXXFLAGS=FLAGS (default: -O2)])],
+ [ac_adolc_cxxflags="$withval"
+- if test x${adolc_debug} == xyes ||
+- test x${adolc_harddebug} == xyes ; then
++ if test x${adolc_debug} = xyes ||
++ test x${adolc_harddebug} = xyes ; then
+ ac_adolc_cxxflags="$ac_adolc_cxxflags -g -O0"
+ fi
+ ac_adolc_cxxflags="$ac_adolc_cxxflags $ac_adolc_openmpflag"
+@@ -411,8 +411,8 @@
+ AC_MSG_RESULT($ac_adolc_cxxflags)],
+ [if test "$ac_shell_cxxflags" = "not_set"; then
+ ac_adolc_cxxflags="-O2"
+- if test x${adolc_debug} == xyes ||
+- test x${adolc_harddebug} == xyes ; then
++ if test x${adolc_debug} = xyes ||
++ test x${adolc_harddebug} = xyes ; then
+ ac_adolc_cxxflags="-g -O0 -Wall"
+ fi
+ else
+@@ -445,7 +445,7 @@
+ ])
+ AC_MSG_RESULT($tapedoc_values)
+
+-if test x$tapedoc_values == xyes; then
++if test x$tapedoc_values = xyes; then
+ AC_DEFINE(ADOLC_TAPE_DOC_VALUES,1,[ADOL-C tape_doc routine computes values])
+ fi
+
+@@ -614,7 +614,7 @@
+ break
+ fi
+ done
+-if test "x${pdir}" == "x/" ; then
++if test "x${pdir}" = "x/" ; then
+ writable=false
+ fi
+ if ! ${writable} ; then
+@@ -626,15 +626,6 @@
+ warn=true
+ fi
+
+-case ${prefix} in
+- ${HOME}|${HOME}/*)
+-if $warn ; then
+- for (( i=5; i>0; i-- )); do
+- echo -ne "\rPlease read the above messages carefully, continuing in ${i} seconds"
+- sleep 1
+- done
+- echo -e "\rPlease read the above messages carefully "
+-fi
+ echo \
+ "
+ *****************************************************************************
+@@ -660,8 +651,6 @@
+
+ *****************************************************************************
+ "
+-;;
+-esac
+ if test "x$enable_static" != "xno" ; then
+ echo \
+ " Linking a user program with a static ADOL-C library will always result