summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cln/cln-1.3.4.ebuild')
-rw-r--r--sci-libs/cln/cln-1.3.4.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/sci-libs/cln/cln-1.3.4.ebuild b/sci-libs/cln/cln-1.3.4.ebuild
deleted file mode 100644
index c57efba5bf28..000000000000
--- a/sci-libs/cln/cln-1.3.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils flag-o-matic
-
-DESCRIPTION="Class library (C++) for numbers"
-HOMEPAGE="https://www.ginac.de/CLN/"
-SRC_URI="https://www.ginac.de/CLN/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/gmp:0="
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.3.2-arm.patch )
-
-pkg_setup() {
- use sparc && append-cppflags -DNO_ASM
- use hppa && append-cppflags -DNO_ASM
- use arm && append-cppflags -DNO_ASM
-}
-
-src_prepare() {
- # avoid building examples
- # do it in Makefile.in to avoid time consuming eautoreconf
- sed -i \
- -e '/^SUBDIRS.*=/s/examples doc benchmarks/doc/' \
- Makefile.in || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=( --disable-static )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use doc; then
- cd "${BUILD_DIR}"
- export VARTEXFONTS="${T}/fonts"
- emake html pdf
- DOCS=("${BUILD_DIR}/doc/cln.pdf")
- HTML_DOCS=("${BUILD_DIR}/doc/")
- fi
-}
-
-src_install() {
- autotools-utils_src_install
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.cc
- fi
-
- find "${ED}" -name '*.la' -delete || die
-}