summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/geos/geos-3.10.2.ebuild')
-rw-r--r--sci-libs/geos/geos-3.10.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sci-libs/geos/geos-3.10.2.ebuild b/sci-libs/geos/geos-3.10.2.ebuild
deleted file mode 100644
index f43f7504f26b..000000000000
--- a/sci-libs/geos/geos-3.10.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Geometry engine library for Geographic Information Systems"
-HOMEPAGE="https://libgeos.org/"
-SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc)
-
- # bug #709368
- $(usex arm '-DDISABLE_GEOS_INLINE=ON' '')
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- use doc && cmake_src_compile docs
-}
-
-src_install() {
- cmake_src_install
-
- if use doc ; then
- HTML_DOCS=( "${BUILD_DIR}"/doc/doxygen_docs/html/. )
- einstalldocs
- fi
-}