summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/kineto/kineto-2021.11.17.ebuild')
-rw-r--r--sci-libs/kineto/kineto-2021.11.17.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/kineto/kineto-2021.11.17.ebuild b/sci-libs/kineto/kineto-2021.11.17.ebuild
new file mode 100644
index 000000000000..4a2841c7a5a9
--- /dev/null
+++ b/sci-libs/kineto/kineto-2021.11.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-any-r1 cmake
+
+CommitId=659a7f99ee737103273ef60551bfe1611c2d2cba
+
+DESCRIPTION="part of the PyTorch Profiler"
+HOMEPAGE="https://github.com/pytorch/kineto"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libfmt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ ${PYTHON_DEPS}
+"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ cd libkineto
+ cmake_src_prepare
+}
+
+src_configure() {
+ cd libkineto
+ cmake_src_configure
+}