summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libcifpp/libcifpp-3.0.0.ebuild')
-rw-r--r--sci-libs/libcifpp/libcifpp-3.0.0.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/sci-libs/libcifpp/libcifpp-3.0.0.ebuild b/sci-libs/libcifpp/libcifpp-3.0.0.ebuild
deleted file mode 100644
index 32bb52f339bb..000000000000
--- a/sci-libs/libcifpp/libcifpp-3.0.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit cmake
-
-DESCRIPTION="Code to work with mmCIF and PDB files"
-HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
-SRC_URI="
- https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz -> components-${PV}.cif.gz
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-libs/boost:="
-RDEPEND="${DEPEND}"
-
-src_configure() {
- cp "${WORKDIR}"/components-${PV}.cif data/components.cif || die
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DCIFPP_BUILD_TESTS="$(usex test)"
- )
- cmake_src_configure
-}