summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libgeotiff')
-rw-r--r--sci-libs/libgeotiff/Manifest3
-rw-r--r--sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch120
-rw-r--r--sci-libs/libgeotiff/libgeotiff-1.7.0.ebuild60
-rw-r--r--sci-libs/libgeotiff/libgeotiff-1.7.1-r3.ebuild (renamed from sci-libs/libgeotiff/libgeotiff-1.6.0.ebuild)53
-rw-r--r--sci-libs/libgeotiff/metadata.xml3
5 files changed, 147 insertions, 92 deletions
diff --git a/sci-libs/libgeotiff/Manifest b/sci-libs/libgeotiff/Manifest
index 7a85e7ff274f..acd4359a5eee 100644
--- a/sci-libs/libgeotiff/Manifest
+++ b/sci-libs/libgeotiff/Manifest
@@ -1,2 +1 @@
-DIST libgeotiff-1.6.0.tar.gz 537175 BLAKE2B 4b1430c9e80cdd4193f474484b295c151ecb9a654248e08527046f1aa35cfab0be59980edad2cc6ae90c1a7b0e03d46fd203affd5b01c83e0fd4435d5e56b2d3 SHA512 4c59598140d6c435a25aff6520e07a01a0153cac526df3b3e1366d5edc43cd82b15099da79ee8a2fb916e858f5a5d7421cfbf96bb485c91fac9e19c7209b7418
-DIST libgeotiff-1.7.0.tar.gz 541931 BLAKE2B 3c0843f8c86d6bbcedf9d07b45d2d676f1ccfaba7b5e40fa7f8d5f290b39da5cfaebe39567eab9e8add1b99042aad51d5104b81c2c05493d18d022d41e5b106b SHA512 8e294b5db89e88dbd4f7eb9d804be788ff3d14a1a14f721e9805b42cc797500596f0473dd8e5be6c1da01b56bdebc872df2b30470a2d96686f308019de10739a
+DIST libgeotiff-1.7.1.tar.gz 542779 BLAKE2B e26a14fcb463f4a9e5a3652b978223da6b11dcb4ec6a3b6068460f929a57e9affafdb652f16fad23a2da4612c6ae3c2624bfb4f26c96fc4290a33f1e0629b726 SHA512 af119040598f4349124848d9788ea1d0d2019e23fc48eaf4b0445320c51e91afa6c7e25b49738bdaf0aa4467a19104b00838d669da27dee77898c489fe5fe4c1
diff --git a/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch b/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch
new file mode 100644
index 000000000000..6fdcd9753f95
--- /dev/null
+++ b/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch
@@ -0,0 +1,120 @@
+https://github.com/OSGeo/libgeotiff/pull/74
+
+From d18deccb461990c826ceee8fbcc57a44502ace2e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 20 Mar 2022 02:55:50 +0000
+Subject: [PATCH] CMake: adopt GNUInstallDirs
+
+This makes it a lot easier for packagers (it happens by default
+if we've setup our environment correctly) to have files installed in the right
+places, including libdir, but also documentation, which can vary.
+
+This works cross-platform still but it means libgeotiff uses the
+standard options which CMake projects tend to use for such locations
+and therefore no special treatment is needed when packaging it.
+
+Fixes: https://github.com/OSGeo/issues/33
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ CMakeLists.txt | 41 ++++++++++-------------------------
+ bin/CMakeLists.txt | 6 ++---
+ 2 files changed, 14 insertions(+), 33 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 001df67..1840258 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,8 @@
+ ###############################################################################
+ PROJECT(GeoTIFF)
+
++include(GNUInstallDirs)
++
+ SET(GEOTIFF_LIB_NAME geotiff)
+ SET(GEOTIFF_LIBRARY_TARGET geotiff_library)
+
+@@ -239,38 +241,17 @@ SET(GEOTIFF_MAN_PAGES
+
+ # ${PROJECT_BINARY_DIR}/geotiff_version.h
+
+-SET(DEFAULT_BIN_SUBDIR bin)
+-SET(DEFAULT_LIB_SUBDIR lib)
+-SET(DEFAULT_INCLUDE_SUBDIR include)
+-
+-# Locations are changeable by user to customize layout of GeoTIFF installation
+-# (default values are platform-specIFic)
+-SET(GEOTIFF_BIN_SUBDIR ${DEFAULT_BIN_SUBDIR} CACHE STRING
+- "Subdirectory where executables will be installed")
+-SET(GEOTIFF_LIB_SUBDIR ${DEFAULT_LIB_SUBDIR} CACHE STRING
+- "Subdirectory where libraries will be installed")
+-SET(GEOTIFF_INCLUDE_SUBDIR ${DEFAULT_INCLUDE_SUBDIR} CACHE STRING
+- "Subdirectory where header files will be installed")
+-
+-# Mark *_SUBDIR variables as advanced and dedicated to use by power-users only.
+-MARK_AS_ADVANCED(GEOTIFF_BIN_SUBDIR GEOTIFF_LIB_SUBDIR GEOTIFF_INCLUDE_SUBDIR)
+-
+-# Full paths for the installation
+-SET(GEOTIFF_BIN_DIR ${GEOTIFF_BIN_SUBDIR})
+-SET(GEOTIFF_LIB_DIR ${GEOTIFF_LIB_SUBDIR})
+-SET(GEOTIFF_INCLUDE_DIR ${GEOTIFF_INCLUDE_SUBDIR})
+-
+ # Install doc files
+ INSTALL(FILES
+ AUTHORS ChangeLog COPYING INSTALL LICENSE README README_BIN README.WIN
+- DESTINATION doc)
++ DESTINATION ${CMAKE_INSTALL_DOCDIR})
+
+ # Install man pages
+-INSTALL(FILES ${GEOTIFF_MAN_PAGES} DESTINATION share/man/man1)
++INSTALL(FILES ${GEOTIFF_MAN_PAGES} DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+
+
+ # Install header files for development distribution
+-INSTALL(FILES ${GEOTIFF_LIB_HEADERS} DESTINATION ${GEOTIFF_INCLUDE_DIR})
++INSTALL(FILES ${GEOTIFF_LIB_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ ###############################################################################
+ # Build libxtiff library
+@@ -323,7 +304,7 @@ if(UNIX)
+ set_target_properties(
+ ${GEOTIFF_LIBRARY_TARGET}
+ PROPERTIES
+- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/${GEOTIFF_LIB_DIR}")
++ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
+ endif()
+ endif()
+
+@@ -348,14 +329,14 @@ target_link_libraries(${GEOTIFF_LIBRARY_TARGET} PRIVATE
+ target_include_directories(
+ ${GEOTIFF_LIBRARY_TARGET}
+ PUBLIC $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}>
+- $<INSTALL_INTERFACE:${GEOTIFF_INCLUDE_DIR}>)
++ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>)
+
+ INSTALL( TARGETS ${GEOTIFF_LIBRARY_TARGET}
+ EXPORT depends
+- RUNTIME DESTINATION ${GEOTIFF_BIN_DIR}
+- LIBRARY DESTINATION ${GEOTIFF_LIB_DIR}
+- PUBLIC_HEADER DESTINATION ${GEOTIFF_INCLUDE_DIR}
+- ARCHIVE DESTINATION ${GEOTIFF_LIB_DIR} )
++ RUNTIME DESTINATION ${CMAKE_INSTALLL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} )
+
+ # Define grouping of source files in PROJECT file (e.g. Visual Studio)
+ SOURCE_GROUP("CMake Files" FILES CMakeLists.txt)
+diff --git a/bin/CMakeLists.txt b/bin/CMakeLists.txt
+index dad465f..c61585c 100644
+--- a/bin/CMakeLists.txt
++++ b/bin/CMakeLists.txt
+@@ -41,6 +41,6 @@ MESSAGE(STATUS "Adding GeoTIFF utilities to build - done: ${GEOTIFF_UTILITIES}")
+ # Targets installation
+
+ INSTALL(TARGETS ${GEOTIFF_UTILITIES}
+- RUNTIME DESTINATION ${GEOTIFF_BIN_DIR}
+- LIBRARY DESTINATION ${GEOTIFF_LIB_DIR}
+- ARCHIVE DESTINATION ${GEOTIFF_LIB_DIR})
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/sci-libs/libgeotiff/libgeotiff-1.7.0.ebuild b/sci-libs/libgeotiff/libgeotiff-1.7.0.ebuild
deleted file mode 100644
index b7d0dbdc7a55..000000000000
--- a/sci-libs/libgeotiff/libgeotiff-1.7.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Library for reading TIFF files with embedded tags for geographic information"
-HOMEPAGE="https://trac.osgeo.org/geotiff/ https://github.com/OSGeo/libgeotiff"
-SRC_URI="https://download.osgeo.org/geotiff/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/5"
-KEYWORDS="amd64 ~arm arm64 ~ia64 ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="debug doc"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
- virtual/pkgconfig
-"
-DEPEND="
- >=media-libs/tiff-3.9.1:0
- >=sci-libs/proj-6.0.0:=
- sys-libs/zlib
- virtual/jpeg:=
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -e "s:-O3::g" -i configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-static \
- --enable-debug=$(usex debug) \
- --with-jpeg="${EPREFIX}"/usr \
- --with-zip="${EPREFIX}"/usr
-}
-
-src_compile() {
- default
-
- if use doc; then
- mkdir -p docs/api || die
- cp "${FILESDIR}"/Doxyfile Doxyfile || die
- doxygen -u Doxyfile || die "updating doxygen config failed"
- doxygen Doxyfile || die "docs generation failed"
- fi
-}
-
-src_install() {
- use doc && local HTML_DOCS=( docs/api/. )
-
- default
-
- find "${D}" -name '*.la' -type f -delete || die
-}
diff --git a/sci-libs/libgeotiff/libgeotiff-1.6.0.ebuild b/sci-libs/libgeotiff/libgeotiff-1.7.1-r3.ebuild
index fb7b410ebb3e..a10ddebd692f 100644
--- a/sci-libs/libgeotiff/libgeotiff-1.6.0.ebuild
+++ b/sci-libs/libgeotiff/libgeotiff-1.7.1-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools
+inherit cmake
DESCRIPTION="Library for reading TIFF files with embedded tags for geographic information"
HOMEPAGE="https://trac.osgeo.org/geotiff/ https://github.com/OSGeo/libgeotiff"
@@ -11,37 +11,32 @@ SRC_URI="https://download.osgeo.org/geotiff/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/5"
-KEYWORDS="amd64 ~arm arm64 ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="debug doc"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
- virtual/pkgconfig
-"
-DEPEND="
- >=media-libs/tiff-3.9.1:0
- >=sci-libs/proj-6.0.0:=
- sys-libs/zlib
- virtual/jpeg:=
-"
+KEYWORDS="amd64 ~arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc jpeg +tiff zlib"
+
+DEPEND=">=sci-libs/proj-6.0.0:=
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ tiff? ( >=media-libs/tiff-3.9.1:= )
+ zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
+BDEPEND="doc? ( app-text/doxygen )"
-src_prepare() {
- default
- sed -e "s:-O3::g" -i configure.ac || die
- eautoreconf
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.1-gnuinstalldirs.patch
+)
src_configure() {
- econf \
- --disable-static \
- --enable-debug=$(usex debug) \
- --with-jpeg="${EPREFIX}"/usr \
- --with-zip="${EPREFIX}"/usr
+ local mycmakeargs=(
+ -DWITH_JPEG=$(usex jpeg)
+ -DWITH_TIFF=$(usex tiff)
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ cmake_src_configure
}
src_compile() {
- default
+ cmake_src_compile
if use doc; then
mkdir -p docs/api || die
@@ -54,7 +49,5 @@ src_compile() {
src_install() {
use doc && local HTML_DOCS=( docs/api/. )
- default
-
- find "${D}" -name '*.la' -type f -delete || die
+ cmake_src_install
}
diff --git a/sci-libs/libgeotiff/metadata.xml b/sci-libs/libgeotiff/metadata.xml
index d3369ac77939..4a868130c3b5 100644
--- a/sci-libs/libgeotiff/metadata.xml
+++ b/sci-libs/libgeotiff/metadata.xml
@@ -5,4 +5,7 @@
<email>sci-geosciences@gentoo.org</email>
<name>Gentoo Geosciences Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">OSGeo/libgeotiff</remote-id>
+ </upstream>
</pkgmetadata>