summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/linbox')
-rw-r--r--sci-libs/linbox/linbox-1.6.3-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/linbox/linbox-1.6.3-r1.ebuild b/sci-libs/linbox/linbox-1.6.3-r1.ebuild
index 1771643dd4d6..cabe5a6d2cf9 100644
--- a/sci-libs/linbox/linbox-1.6.3-r1.ebuild
+++ b/sci-libs/linbox/linbox-1.6.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,7 +34,11 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-1.6.3-pc.patch" )
pkg_pretend() {
- [[ "${MERGE_TYPE}" != "binary" ]] && use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {